10

The configuration:

  • Windows 10 (64-bit) (Fresh installation)
  • Cygwin64 fresh installation (downloaded setup-x86_64.exe)

Installation looks like it worked. However, when I try to launch the newly created shortcut, the window closes immediately.

The shortcut target is C:\cygwin64\bin\mintty.exe -i /Cygwin-Terminal.ico -.

If I modify it to C:\cygwin64\bin\mintty.exe -h always -i /Cygwin-Terminal.ico -, the window stays open, but the message inside is Failed to run /Cygwin-Terminal.ico: Permission denied.

The following might be a red herring, but I suspect it is actually related to the problem: If I run cmd and cd c:\cygwin64, I can run Cygwin.bat, however the prompt is Unknown+User@DESKTOP-6SQ80GV ~, which is not actually my username. /cygdrive/c/cygwin64/Cygwin-Terminal.ico is owned by Unknown+User with group of Administrators, and has permissions of 644. If I chmod +x it, the error message in the window changes to:

C:/cygwin64/sbin/nologin.exe: error while loading shared libraries: ?: cannot open shared object file: No such file or directory
/sbin/nologin: Exit 127

I've done some quick searching and my google-fu is apparently failing, as I'm not finding much to go on. I'm guessing I could thrash around and eventually make things work, but I'm wondering if anyone here knows "what is the right way to fix this problem?".

3 Answers 3

17

I had the same issue after updating my Cygwin installation on Windows 7. The problem wasn't the update itself but the activation of the cygserver service. If you have any Cygwin service installed in your Windows machine try solving the problem by setting these services to either manual start or automatic start but delayed.

The problem is that the service 'cygserver' will cache account information and provide it to other Cygwin applications and services like described in https://cygwin.com/cygwin-ug-net/ntsec.html#ntsec-mapping-caching. The account data is retrieved from Microsoft LDAP service which needs more time to start than the cygserver service. Setting the cygserver service to delayed automatic start will resolve this problem. But keep in mind that the start of the cygserver service may delayed a couple of minutes after (re)boot of Windows.

Hope this helps :-)

1
  • 2
    To make cygserver run automatically but delayed, do the following: Press Win+R to open the Run console and enter services.msc. Find CYGWIN cygserver in the services list, right-click it and select Properties, and choose Automatic (Delayed Start) for the Startup type option, under the General tab.
    – gpanders
    Commented Mar 28, 2019 at 17:56
5

To expand on Izzet Beltir's answer, you can simply restart the service if you want to get Cygwin working immediately:

  1. Open a command line or PowerShell window - with elevated privileges (Run As Administrator)

  2. Run these commands:

    net stop cygserver
    net start cygserver
    

    (for earlier versions of Cygwin the service name may be cygservice rather than cygserver.)

You should now be able to open a Cygwin terminal just fine.

0
2

for the issue of
Unknown+User@DESKTOP-6SQ80GV

you need to read
https://cygwin.com/cygwin-ug-net/ntsec.html#ntsec-mapping-nsswitch

as cygwin seems currently unable to recover from SSID your user profile. As W10 is recent, may be something in your configuration has not yet been considered, so best place for extra support is the main mailing list:
https://www.cygwin.com/cygwin/lists.html
https://www.cygwin.com/ml/cygwin/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .