33

In Windows 10, the Windows Explorer shortcut on the taskbar has a different context menu than previous versions of Windows, and is missing the "Run as..." option (while holding the shift key).

How can I open Explorer as a different user?

6
  • 1
    The "Run as a different user" shows in Windows 10's Explorer when you shift-click a runnable file just like it did in previous versions of Windows, so as-is your question is unclear. Please edit your question and include more information about your specific scenario (what exactly are you trying to run as a different user, Explorer itself, or another program you've explored to?), and what you've tried already to resolve it. Oct 13 '15 at 13:25
  • I would like to use the fixed task bar icon of Windows Explorer to run with a different user context like I did in previous Windows version. From the @CFreitas I must create a new shortcut to the executable and use this. Oct 13 '15 at 13:37
  • 2
    I do not understand why the negative in question as it's a legitim question from the new Windows 10 interface and a break with previous Windows 10. Try to find about it on Google and you found lots of registry changes that do not solve the problem so I think this is a good place to put this kind of question. Oct 13 '15 at 13:39
  • @MaxBündchen - As somebody already explained. Your question is not clear in its current form. Since this functionality has not changed since Windows XP.
    – Ramhound
    Oct 13 '15 at 13:41
  • Now that you've clarified what you're trying to do I've edited your question to better explain what's different, and why it's not just the same as previous versions of Windows. I've also retracted my close vote. PS: please don't edit your chosen solution into your question, it doesn't help anyone and it goes against the Q&A format. :) Oct 13 '15 at 13:52
16

There's probably a better way to do it but if you go to c:\windows, find explorer.exe, Shift+right click and the option "Run as different user" will be there.

4
  • 16
    This didn't work for me, I got an error Windows cannot access the specified device, path or file. You may not have the appropriate permissions to access the item. I've opened a new question superuser.com/questions/1127088/…
    – binaryfunt
    Sep 22 '16 at 11:07
  • To run Explorer as administrator you need to have administrator access. You cannot do it with a Standard User. Standard users do not have direct access to Windows folder.
    – CFreitas
    Jul 24 '17 at 8:22
  • 5
    that's not the problem
    – binaryfunt
    Jul 24 '17 at 11:49
  • We can get to the Windows folder and the file - it's the runas that fails.
    – RBerman
    Nov 23 '21 at 20:26
9

All the answers above are wrong (sorry)...

This process will enable what you are after:

1.Take ownership of reg key HK_CLASSES_ROOT\AppID{CDCBCFCA-3CDC-436f-A4E2-0E02075250C2}, and grant yourself Full Control. This key controls how explorer is allowed to launch

  1. Rename the subkey from "runas" to "_runas". If you receive an error doing this, then you probably didn't complete step one correctly.

Now try a runas on explorer.exe and it should run as your alternate user.

3
  • 3
    By accepting an answer, OP is clearly indicating that one of them is Right. While it may not have worked for you, that just means that while your symptoms were similar, the underlying problem was different. Welcome to SuperUser. Adding good answers and other ways to get to the solution is good. Calling everyone else "wrong" while doing so can cause unnecessary friction. Mar 26 '19 at 15:39
  • 2
    This one is working marvelously for me.
    – Geco Mynx
    Jul 2 '19 at 6:02
  • 1
    Apparently, although I expect this (yours) is the most-correct answer, there's no way to do this safely. superuser.com/questions/1127088/… Aug 19 '20 at 19:01
0

You can also open command prompt and type:

runas /user:domain\user explorer.exe

It will then prompt for a password and then open.

2
  • 2
    That doesn't work. Explorer.exe will already be running as your regular user because it manages the taskbar and windows, etc. When you do this runas, it simply opens another window under the same process, not as another user. Sep 5 '16 at 19:13
  • 1
    Combining this answer with John Lynch's answer works well. I've created a shortcut with Narzard's command and, with the registry change, it's a one-click solution (although I do have to type in my password each time).
    – Dubs
    Nov 11 '19 at 19:02
0

For me, the only use case for running explorer.exe as a different user is to get access to shared folders on another computer. So accessing paths like:

\\computerName\c$\myFolder

I would recommend skipping the whole "run as" approach for this use case and just browse to the path. If you don't have permissions explorer will ask for credentials. Windows 10 Access denied pop-up

BTW, for Windows 10 the explorer.exe program title is now "File Explorer".

3
  • I think your answer needs more information and steps to achieve the goal. We all are equally responsible to maintain the standards of the community. Refer superuser.com/help/how-to-answer help you to improve. Jun 1 '18 at 17:58
  • What if I have access to read the target folder, but I need to use a different account's permissions to write something at the target path? Explorer does not ask me for credentials in that case. Jan 22 '21 at 21:47
  • None of the other answers worked on Windows Server. This was helpful. Thanks.
    – FLICKER
    Jun 15 '21 at 11:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.