I want to change a Windows 7 Registry key in

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced - Hidden

I ran regedit as administrator. But when I was trying to modify that key, it doesn't allow me to change and reports error as

Cannot edit: error writing the value's new contents

So why can't I change the registry key even in administrator mode? How to solve this problem in Windows 10?

  • What permissions do you have in the registry key ? Value that you are trying to add, is it a REG_DWORD ? – pun Oct 15 '15 at 3:10

Interesting. I'm on Windows 10 Pro x64 and I can edit the value.

Right click on Advanced and choose "Permissions".

Click your user name and make sure you have full permissions:

If you don't, try allowing yourself full control (if the boxes are available).

If they're greyed out like in my screenshot, but you don't have full access, you can try to take ownership of the object by clicking Advanced

Then next to Owner click Change:

Type your username into the box and then press Check Names. Press Okay, then before you press Okay again make sure the following is selected:

  • 1
    Thanks for answering, but I still have this problem, I did everything but I can't. – Miguel Hernandez Oct 15 '15 at 4:12
  • 1
    I did everything you told me, I added myself as owner and I still get the same message – Miguel Hernandez Oct 15 '15 at 4:23
  • 1
    Go here and continue from Step 4 and see if that works (you already did step 1-3). – Insane Oct 15 '15 at 4:32
  • 2
    @MiguelHernandez - Provide us more information. Provided us screenshots of the permissions you currently have set on the key. This is the correct answer, I assume, after you did this you restarted? – Ramhound Oct 15 '15 at 12:07
  • 1
    If you're confused what he means when he says he did everything and it didn't work: try installing Forti anti-virus, then try to take control, grant yourself full control, and change the Start option of FA_Scheduler from 3 (auto-start) to 2 (manual start). You'll notice that taking ownership, and giving yourself full control has no effect. – Ian Boyd Nov 30 '17 at 22:21

If you are logged in with a Microsoft account (usually this happens when you have a local user, then you try to log in into the Windows Store).

You can add your Microsoft account into the users group by right click the registry you want to change, then permissions, and click in the advanced option.

Next to the listed owner you can add your Microsoft account (click on change and then use your e-mail), so this account can take ownership of any file.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.