23

I selected all the text in a document and colored it all black (which is what I wanted to do). I didn't realize that the document had some hyperlinks in it (several pages in, in a very long document), so now I can't tell where the hyperlinks are, although I know it's working. Since there are many links, how can I turn the links back to underlined blue (as they should be) without having to go to each one and turning it blue?

22

Resetting the style of all Hyperlinks back to default requires a VBA Macro.

Code:

Sub RestoreHyperlinkStyle()
    Dim hl As Hyperlink
    For Each hl In ActiveDocument.Hyperlinks
        hl.Range.Style = wdStyleHyperlink
    Next
End Sub

Steps:

  1. Press Alt+F11 to open Microsoft Visual Basic for Applications.
  2. Double-click on "ThisDocument".
  3. Paste the code from the block above into the editor.
  4. Press F5 to run the code.
  5. Delete the code from the editor window to prevent Word from saving with Macros.
11

Try the following, it works in Word 2013 and I think it should work in 2010 as well:

  • From the Home tab on the ribbon, choose Find -> Advanced Find...
  • Leave Find what blank.
  • At the bottom, choose Format -> Style...
  • Choose Hyperlink and press OK to close the dialog and return to the previous one.
  • Choose Find In -> Main Document
  • All the hyperlinks will be highlighted.
  • From the ribbon, choose Styles -> Clear Formatting. The default colour will be restored.

enter image description here

  • 3
    Caveat: This would not work if styles were removed (Select text, Ctrl+Space) – Steven Oct 15 '15 at 16:29
9

But sometimes you just want to set one hyperlink back to blue. For example: You create an email in Outlook (same word editor) and paste a hyperlink into it. You click on the hyperlink to make sure it's going where you intended - that turns it purple. You don't want to send the email with a purple hyperlink.

So, just right-click on the hyperlink and from the context menu select "Edit Hyperlink". It brings up the edit dialog box. Click on "OK". The hyperlink is returned to it's original blue state. Simple and quick.

6

Similar to James' solution, but this reassigns the style vs. clearing formatting...

Assuming the links are still styled as Hyperlinks (which they should be if all you did was change the Font colour):

  • From the Home tab on the ribbon, choose Replace (or Ctrl+H).
  • Click the More >> button to expand the dialog.
  • Click on the blank Find what field.
  • At the bottom, choose Format -> Style...
  • Choose Hyperlink and press OK to close the dialog and return to the previous one.
  • Click on the blank Replace with field.
  • At the bottom, choose Format -> Style...
  • Choose Hyperlink and press OK to close the dialog and return to the previous one.
  • Click Replace All.

Find/Replace Dialog

2

There is a simple way to do this.

  1. On the document you want to make your hyperlinks back to normal blue, press Shift + Ctrl + Alt + S.
  2. A box will appear (Styles). Scroll the box content to find FollowedHyperlink.
  3. Click on the little drop-down triangle. On the drop-down menu click on Update FollowedHyperlink to match selection.

Just that! The beautiful blue color is back to all your hyperlinks. (Consider that if you ever click on hyperlinks later on this document, the color will not change anymore.)

  • On a Mac it's Command + Option + Shift + S – Pedram Sep 27 '17 at 21:49
1

Just make sure your cursor is on the pink hyperlink, press "Insert/Link/OK" and your hyperlink will turn back to blue - essentially, you just re-establish the link.

  • 1
    ‘‘… there are many links [in the document]; how can I turn the links back to underlined blue … without having to go to each one …?’’ – Scott Oct 10 '17 at 23:49
  • This is the best answer (for one or two links): The instructions on Mac "Insert... Hyperlink... OK" – Briford Wylie 2 days ago
0

For me, none of those worked in Word 365.

The easiest way that I found is:

  1. press Shift+Ctrl+Alt+S.
  2. revert/remove any unusual style formatting from there. in my document there were hyperlink.0 and hyperlink. i removed both.
  3. press Ctrl+A (to select all document)
  4. click on small "clear all formatting" icon just above font color icon.
  5. that's it. it will remove all the formatting to default ones, removing all black hyperlinks to default/blue hyperlinks..

Not the answer you're looking for? Browse other questions tagged or ask your own question.