0

I originally posted this on the network engineering part, and they said that superuser would be the better place to ask this. So here I am!

I have tried asking this question on the OpenVPN forum, but no repsonses, and I have searched for hours for answers as well as troubleshooting the issue. I am running Windows 8.1 x64.

When I install the OpenVPN software, it will install until it gets to the TAP driver. The TAP driver will then fail. I have tried running the driver as admin, un-blocking it in the properties, shut off firewalls, and AVs, changed registry value for networking to config.bak, installed different versions, uninstalled "unknown" devices, deleted the NET key in HKLM/SYSTEM/Enum, tried installing it in safe mode, disabled driver signatures, ran sfc /scannow, gave rundll.exe privilages and still nothing will work.

No matter what I do, I get an error. So here is the log from the TAP installer:

>>> [Device Install (UpdateDriverForPlugAndPlayDevices) - tap0901]
>>> Section start 2015/10/14 23:23:26.442
    cmd: "C:\Program Files\TAP-Windows\bin\devcon.exe" install "C:\Program Files\TAP-Windows\driver\OemWin2k.inf" tap0901
    dvi: {Update Device Driver - ROOT\NET\0005}
    dvi: {Build Driver List} 23:23:26.458
    dvi: Searching for hardware ID(S):
    dvi: tap0901
    sig: {_VERIFY_FILE_SIGNATURE} 23:23:26.458
    sig: Key = oemwin2k.inf
    sig: FilePath = c:\program files\tap-windows\driver\oemwin2k.inf
    sig: Catalog = c:\program files\tap-windows\driver\tap0901.cat
    sig: Verifying file against specific (valid) catalog failed! (0x800b0109)
    sig: Error 0x800b109: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider
    sig: {_VERIFY_FILE_SIGNATURE exit(0x800b0109)} 23:23:26.489
    sig: {_VERIFY_FILE_SIGNATURE} 23:23:26.489
    sig: Key = oemwin2k.inf
    sig: FilePath = c:\program files\tap-windows\driver\oemwin2k.inf
    sig: Catalog  = c:\program files\tap-windows\driver\tap0901.cat
    sig: Success: File is signed in Authenticode(tm) catalog.
    sig: Error 0xe0000241: The INF was signed with an Authenticode(tm) catalog from a trusted publisher
    sig: {_VERIFY_FILE_SIGNATURE exit(0xe0000241)} 23:23:26.505
    dvi: Created Driver Node:
    dvi: HardwareID - tap0901
    dvi: InfName - c:\program files\tap-windows\driver\oemwin2k.inf
    dvi: DevDesc - Tap-Windows Adapter V9
    dvi: Section - tap0901.ndi
    dvi: Rank - 0x00ff0000
    dvi: Signer Score - Authenticode
    dvi: DrvDate - 07/02/2012
    dvi: Version - 9.0.0.9
    dvi: {Build Driver List - exit(0x00000000)} 23:23:26.505
    dvi: {DIF_SELECTBESTCOMPATDRV} 23:23:26.505
    dvi: Using exported function 'NetClassInstaller' in module 'C:\WINDOWS\system32\NetCfgx.dll'.
    dvi: Class installer == NetCfgx.dll,NetClassInstaller
    dvi: Using exported function 'WlanDeviceClassCoInstaller' in module 'C:\WINDOWS\system32\wlanist.dll'.
    dvi: CoInstaller 1 == wlaninst.dll,WlanDeviceClassCoInstaller
    dvi: Using exported function 'WwanDeviceClassCoInstaller' in module 'C:\WINDOWS\system32\wwaninst.dll'.
    dvi: CoInstaller 2 == wwaninst.dll,WwanDeviceClassCoInstaller
    dvi: CoInstaller 1: Enter 23:23:26.505
    dvi: CoInstaller 1: Exit
    dvi: CoInstaller 2: Enter 23:23:26.505
    dvi: CoInstaller 2: Exit
    dvi: Class installer: Enter 23:23:26.505
    dvi: Class Installer: Exit
    dvi: Default installer: Enter 23:23:26.505
    dvi: {Select Best Driver}
    dvi: Class GUID of device remains: {4d36e972-e325-11ce-bfc1-08002be10318}.
    dvi: Selected:
    dvi: Description - [Tap-Windows Adapter V9]
    dvi: InfFile - [c:\program files\tap-windows\driver\oemwin2k.inf]
    dvi: Section - [tap0901.ndi]
    dvi: {Select Best Driver - exit(0x00000000)}
    dvi: Default installer: Exit
    dvi: {DIF_SELECTBESTCOMPATDRV - exit(0x00000000)} 23:23:26.505
    ndv: Forcing driver install:
    ndv: Inf Name - oemwin2k.inf
    ndv: Driver Date - 07/02/2012
    ndv: Driver Version - 9.0.0.9
    sto: {Setup Import Driver Package: c:\program files\tap-windows\driver\oemwin2k.inf} 23:23:26.505
    inf: Provider: TAP-Windows Provider V9
    inf: Class GUID: {4d36e972-e325-11ce-bfc1-08002be10318}
    inf: Driver Version: 07/02/2012,9.00.00.9
    inf: Catalog File: tap0901.cat
    sto: {Copy Driver Package: c:\program files\tap-windows\driver\oemwin2k.inf} 23:23:26.520
    sto: Driver Package = c:\program files\tap-windows\driver\oemwin2k.inf
    sto: Flags = 0x00000007
    sto: Destination = C:\Users\Andy\AppData\Local\Temp\{7c0d8e2c-e951-7842-91dc-005ca0be2155}
    sto: Copying driver package files to 'C:\Users\Andy\AppData\Local\Temp\{7c0d8e2c-e951-7842-91dc-005ca0be2155}'.
    flq: Copying 'c:\program files\tap-windows\driver\oemwin2k.inf' to 'C:\Users\Andy\AppData\Local\Temp\{7c0d8e2c-e951-7842-91dc-005ca0be2155}\oemwin2k.inf'.
    flq: opying 'c:\program files\tap-windows\driver\tap0901.cat' to 'C:\Users\Andy\AppData\Local\Temp\{7c0d8e2c-e951-7842-91dc-005ca0be2155}\tap0901.cat'.
    flq: Copying 'c:\program files\tap-windows\driver\tap0901.sys' to 'C:\Users\Andy\AppData\Local\Temp\{7c0d8e2c-e951-7842-91dc-005ca0be2155}\tap0901.sys'.
    sto: {Copy Driver Package: exit(0x00000000)} 23:23:26.536
    sto: Failed to call to import driver package. Error = 0x0000000D
    sto: {Setup Import Driver Package - exit(0x0000000d)} 23:28:26.538
    ndv: Driver Package import failed for device
    ndv: Error 13: The data is invalid
    ndv: Installing NULL driver

So to me, this code is telling me what is wrong?

Sig: Verifying file against specific (valid) catalog failed! (0x800b0109)
Error 0x800b0109: A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider.

So, is it their certificate or myn? Is there anyway to fix this?

So I found this article, Troubleshooting Driver Signing and it states that to install it a driver that is not "verifying file against specific (valid) catalog failed." So I went to the Add Hardware and said that I had the disk, and input the .inf file for the TAP driver and it states that

The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems.

Even though the downloads says it is for openvpn-install-2.3.4-I604-x86_64.exe. So what do I do here?

Please help guys, I really need OpenVPN, and I have been troubleshooting this for days now.

Thanks in advance!!

  • This error message can be caused by many things. Here is a useful troubleshooting resource, if you haven't seen it: community.openvpn.net/openvpn/wiki/…> – Isaac Hanson Oct 15 '15 at 22:19
  • @ Isaac: I suspect the OP has already seen that doc ..as per this post. @jetlabb: It may be possible that you initial download was corrupted .. – dotvotdot Oct 15 '15 at 22:30
  • Also make sure your PC is fully up to date – dotvotdot Oct 15 '15 at 22:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.