0

I apologize if this is convoluted. I've tried so many different ways of getting this to work that I'm getting them all mixed up.

With the launch of Mac OS 10.11 El Capitan, we've encountered some serious issues with our deployment strategies. First, the new SIP prevents -bless commands from working, preventing us from doing our multiple-OS configuration boot system.

But a bigger problem at the moment is that we can't even image any Mac newer than 2012.

We use DeployStudio both to create the images and to deploy them using the NetBooter with automated workflows set to each serial number (We have about 160 Macs). Our server is running the latest DeployStudio (1.6.15) on OSX10 using Server 4.0.3. The image is applied to the Mac successfully, but upon the first boot into the OS, the standard globe will appear, then the OSX11 progress bar and finally result in a prohibitory symbol (circle with a slash through it).

The OSX11 Mac Image was created initially on a Mid-2011 21.5" iMac. I have since recreated from scratch (Erased Drive, Installed 10.11 from App Store Installer) on a Mid-2015 MacBook Pro to eliminate the possibility of some incompatibility. However, the result was identical.

I've tried to upgrade the server as well. I went to OSX 11 running Server 5 with the same DeployStudio version. However, after creating the NetBoot for that server, every Mac that boots into it immediately Kernel Panics with the following error:

"Unable to find driver for this platform: \"ACPI\".\n'@/Library/Caches/com.apple.xbs/Sources/xnu/xnu-3247.1.106/iokit/Kernel/IOPlatformExpert.cpp:1665"

It appears this is a known issue with DeployStudio and 10.11. Apple removed some of the files that DeployStudio depended on.

I'm at a complete loss. Does anyone have any recommendations?

1

I apologize if this is convoluted. I've tried so many different ways of getting this to work that I'm getting them all mixed up.

I feel your pain, your post explains everything that I have just gone through and hoping for an answer to this question.

Never-the-less, Deploy Studio has released 1.6.17. http://www.deploystudio.com/downloads/deploystudio-server-1-6-17

Only Problem

If you are not using SSL for your Deploy Studio you will run into this problem. With Deploy Studio Assistant it will not connect to your Deploy Studio Server. Have a look at this Deploy Studio forum fix. I tried the solution to add the text at the end of the Info.plist file but it didn't work for me, maybe someone else will have more luck. I just did what was suggested by the OP:

  • Uninstall 1.6.17
  • Reinstall 1.6.16
  • Enable SSL with DeployStudio Assistant - Set up a DeployStudio Server
  • Install 1.6.17 over the top of 1.6.16

http://www.deploystudio.com/Forums/viewtopic.php?id=7465

With this I was able to NetBoot a Mac without the Kernel Panic!

Good Luck

0

This particular issue was actually specific to Fusion Drive Macs and only Fusion Drive Macs. As someone suggested, all that was needed was to check "Preventative Volume Repair."

However, Tyelford's solution is far more thorough and better in the long term. For the time being, I've decided not to update the server to 10.11.

  • I was having this issue with Macs without Fusion Drives. All my Macs have SSD's. Either way still have troubles accessing Deploy Studio Assistant on 1.6.17 with SSL enabled. It is working but can't change anything. – tyelford Dec 10 '15 at 1:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.