3

I am using a shared Wi-Fi connection. I am the only person who is not getting good Internet speed. Other devices receive great speed.

My system setup is:

When I connect to other networks, I get good speed. What could be wrong? Here are the results of tests on Speedtest.net:

My roommate is getting a speed of:

  • download: 24.5 mbps
  • upload: 7.32 mbps

My laptop is giving:

  • download: 0.75 mbps
  • upload: 0.21 mbps

EDIT:

Router Security Type:

  • No Security
  • WEP 64 bits
  • WEP 128 bits
  • WPA-PSK (TKIP)
  • WPA2-PSK (AES)
  • WPA/WPA2-PSK (TKIP/AES)

I tried with WPA/WPA2-PSK and WPA2-PSK and failed. I am still receiving poor speed.

4
  • Please edit your question to add more specifics such as what OS you are on, what hardware you are using for your system—including full make and model—as well as details on your own Wi-Fi connection hardware inkling what the make/model of the router is. Without these details the question is too vague to answer. – Giacomo1968 Oct 16 '15 at 1:46
  • @jake edited my question – Touchstone Oct 16 '15 at 1:54
  • According to online specs, the Dell Inspiron 1545 can only do 802.11b/g speed. And the Sagecom Fast 5250 Home Hub 2000 can handle 802.11b/g/n/ac. That alone would not explain the slowdown in speed since 802.11g should be fine for most home Internet connectivity up to 50Mbps. So exactly what do you believe your “slow” speed is? Can you post results from speedtest.net? – Giacomo1968 Oct 16 '15 at 2:02
  • @JakeGould edited my question and added the speed. – Touchstone Oct 16 '15 at 2:08
0

Assuming that you tried updating the notebooks wireless driver (start with this if You haven't done it before) and that did not resolve the problem here is my experience:

I met similar cases where the encryption was the main problem. The notebook was an older model and could not handle the routers AES right.

It caused slowness and connection drops. Try to enter the routers wireless menu and if You have the option, set the encryption type to TKIP or WPA personal (not WPA2)

You can read more about TKIP and AES here

2
  • edited my question. – Touchstone Oct 17 '15 at 2:54
  • @Touchstone And did You try with •WPA-PSK (TKIP) and •No Security? Is the QoS enabled on the router? – Divin3 Oct 17 '15 at 6:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.