0

I recently changed my windows IP address to 172.16.115.X and the default gateway address is 172.16.112.1. So I got a warning that the gateway and my address are not in the same subnet, which is fine. I ignored the warning because that is the configuration in my lab.

But how do I not let/allow windows to use the default ip which is 169.X.X.X (something like that). How do I force windows to use the assigned IP?

2
  • Since the two IPs 115.x and 112.x are in two subnets( with the subnet mask 255.255.255.0), both are not interchangeable without modifying the mask. The 169.x.x.x is the automatically assigned private IP .
    – Nikhil_CV
    Oct 16 '15 at 9:04
  • To disable [APIPA](www.webopedia.com/TERM/A/APIPA.html) , you need to modify registry. Ref 1 Ref2.
    – Nikhil_CV
    Oct 16 '15 at 9:11
1

169.254.0.0/16 is used for IPv4 address autoconfiguration, and is specified as such by RFC 3927. See also the Wikipedia article on link-local IPv4 addresses.

Microsoft calls it "Automatic Private IP Addressing". It may also be called "auto-IP" or by its abbreviation APIPA.

Disabling APIPA will prevent Windows from locally assigning link-local IP addresses to network interfaces.

To disable APIPA, and thus prevent Windows from assigning a 169.254.0.0/16 IPv4 or fe80::/10 IPv6 address to network interfaces where no working IP configuration methods exist, you can refer to Microsoft KB article 244268. In short:

  1. Use the registry editor (running as administrator) to navigate to either HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\adaptername (a single network adapter) or HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters (the entire computer).
  2. Create or edit a DWORD value named IPAutoconfigurationEnabled and set its value to 0. A value of 0 indicates that APIPA is disabled.
  3. Reboot your system.

To restore the default, delete the IPAutoconfigurationEnabled value. To explicitly state the current default (that you want APIPA enabled), set the value to 1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.