2

I am having trouble repairing my Windows 10 boot loader. I have tried booting into the Windows 10 installer usb and doing the Repair Start Up there. I have tried the solution suggested here: How to fix Windows 10 boot loader from Windows . I have also tried the fix detailed here: http://www.fixedbyvonnie.com/2013/12/how-to-repair-the-efi-bootloader-in-windows-8/ . Neither of these fixed the issue for me.

The history behind the issue is this: I initially installed Windows 8.1 onto my primary boot ssd. I later repartitioned and installed Arch Linux onto a second partition on the same drive. I then installed Windows 10 over top of the Arch Linux installation. I later removed the Windows 8.1 partition and re-expanded so that Windows 10 was the only OS installed on the drive. (I later added a second ssd with Antergos Linux on it.) This series of installations seem to have left the Arch gummiboot boot loader on the drive, though if I just booted the drive directly it always dumped me directly into the Windows boot loader, so I didn't even realise the Linux gummiboot loader was still present.

I have been trying to get a GPU passthrough setup working [https://www.reddit.com/r/pcmasterrace/comments/3lno0t/gpu_passthrough_revisited_an_updated_guide_on_how/ ] and I couldn't get Windows working in the Virtual Machine, and determined that it seemed to be because of the boot loader. I tried various methods of fixing this (as above), but nothing worked. So I looked at the ssd Windows 10 was installed on and saw that there was still a ext4 partition (alongside of a fat32 partition, which is where Windows had it UEFI boot loader). I deleted the ext4 partition and set the "boot" flag on the fat32 partition. After doing this, now not only did running Windows in a VM no longer work, but I was no longer able to boot directly into Windows. Now I get a "PROCESS1_INITIALIZATION_FAILED' error on boot.

I went into the fat32 partition and found that there was still a gummiboot directory. I tried deleting that, but it made no difference. I then deleted all files from the fat32 partition and re-tried the solutions from the first paragraph. Still nothing works. Though I now have 6 different (all non-working) Windows Bootloader entries when I go into the motherboard BIOS.

Is there any way of fixing this, aside from completely reinstalling Windows 10? And, if I have to reinstall Windows 10, is there any way to save the current partition where the actual Windows 10 installation is (as opposed to the EFI/boot partitions) and dump it over top of a new installation? (And how do I remove all of the Windows 10 bootloader entries from BIOS?)

8

Assuming Windows is installed to GPT disk.

To successfully boot Windows 10 (also Windows 8.1/8/7) on UEFI firmware you need exactly 3 partitions on a GPT styled disk:

  1. EFI System partition (usually 100 MB - 500 MB)

  2. Microsoft Reserved partition (exactly 128 MB)

  3. Windows partition (at least 20 GB for 64-bit Windows)

Eventually you could have a separate "recovery" partition.

The presence of first three partition mentioned is mandatory or else Windows cannot boot.

The command to fix BCD + boot loader + boot manager and write a boot entry in NVRAM is bcdboot.exe -

bcdboot N:\Windows /s Z:

where N: is Windows partition and Z: is EFI System partition. (Later you have to fix recovery loader separately using ReAgentC.exe command.)

You can use also bootrec.exe command from recovery environment to fix booting (not always successful but fixes also recovery loader).

No need to say that you have to boot Windows installation/recovery media (USB/DVD) using EFI boot.

UEFI booting does not use MBR and partition boot records for booting but it may help to rewrite MBR (should be a protective MBR on GPT disk) using bootsect.exe command in case MBR was tampered by Linux install. Windows does not like "mixed" MBR format on GPT disk.

Reference: Repair Windows BCD on UEFI and BIOS

Hope this helps.

  • I'll have to try that. I did use bcdboot as part of one of the solutions I had tried, so I'm not necessary that hopeful... – emacsomancer Oct 17 '15 at 3:26
  • I don't think the MSR Partition is required to boot Windows. There's plenty of resources online indicating that it isn't. – Addison Feb 5 at 2:29
  • Can confirm that you do NOT need the Microsoft Reserved Partition to boot or even install Windows 10. I just installed using only an ESP and a single Primary Data partition – Addison Feb 5 at 4:05
  • does there not exist a linux utility to create the required windows files? after all,. the efi boot partition data is just normal files – Johannes Schaub - litb Mar 22 at 22:20
  • You could use a file manager to copy all boot related files (and manage Windows security settings) if: 1. You know where to take the files from. (Windows directory) 2. Know exact security settings! Then you have to edit BCD file (registry format) if some boot parameter has changed! – snayob Apr 1 at 16:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.