I installed Kali Linux a month ago. It was good until today.

When I submit username and password the box disappears and reappears again asking about username and password. It shows no error. I just can't login.

I also tried to make new account and try login but same problem occur. I don't wanna reinstall it.

  • Since it doesn't show an error, it's probably not a problem with the account. I suspect that there is an error with whatever desktop environment/window manager is started. Can you use <Ctrl>+<Alt>+<F1> to switch to a console and login there? It might be useful to look for errors in ~/.xsession-errors and /var/log/Xorg.0.log
    – user482194
    Oct 17, 2015 at 12:06
  • yes i can use <Ctrl>+<Alt>+<F1>
    – Frank
    Oct 17, 2015 at 12:27
  • If you have reason to believe your installation of Kali Linux was compromised, as is the case here, you really have to reinstall it from a known-good source. Oct 17, 2015 at 12:31
  • /var/log/Xorg.0.log it says permissson denied
    – Frank
    Oct 17, 2015 at 12:42
  • Recently I have this login problem while run Kali on Virtual Box. It turn out that I was out of space on virtual disc drive. When I remove some files, that I have there I was able to log in like always.You can enter tty from Virtual Box using your hot key -- default is your Right Ctrl and F1. If you want to exit from tty to GUI use Right Ctrl and F7.
    – Marcin
    Jan 11, 2021 at 17:30

8 Answers 8


I saw this post on a quest for a solution to the same problem. I couldn't find an answer. What i then tried doing was this and it worked.

  1. While in the username screen press Ctrl+Alt+F1
  2. Login with root.
  3. Type sudo apt-get update
  4. Type sudo apt-get upgrade
  5. Type sudo reboot

After that the system rebooted and the login worked! I hope this works for who ever finds this post.

  • 4
    for me in VMWare the combination was Ctrl + Alt + F2
    – michnovka
    Oct 29, 2016 at 20:15
  • For vmware users on mac, check this out.
    – HamZa
    Feb 9, 2017 at 10:15

This seems to happen when a lot of updates are run. It happened to me when using the 2016.2 OVA and running a full update and upgrade. Here are the steps that worked:

  1. Ctrl + Alt + F1 at the login screen
  2. dpkg --configure -a

This will finish the updates that were interrupted.


If all those precious answers fail, drop in a tty using Ctrl+Alt+F3 or any other Function key and login. Now, create a directory first with mkdir -p ~/dotfiles_backup. Then, execute the following command:

find ~ -name '.*' -maxdepth 1 -type f -exec mv {} ~/_dotfiles_backup/ \;

If after this you're still unable to login, run it again but remove the -type f option. If you get Operation not permitted or Permission denied, use sudo.

This will reset most of your saved preferences. After you're able to login again, you can try to restore them one by one and see what was causing the problem.


For me it was because of the vnc server (tightvncserver) that was running (for some reason). I'm running Kali on a VMware ESXi host using the Embedded Host Client and was getting this problem after I enabled the vnc server by creating a script in /etc/init.d/ and using the systemctl enable command. I was able to open another virtual terminal using the instructions here. Then I used systemctl stop vncserver, then disabled it, rebooted and everything worked.


None of those work for me but I fixed it by just downloading another desktop

XFCE dektop:

apt-get install kali-defaults kali-root-login desktop-base xfce4 xfce4-places-plugin xfce4-goodies



apt-get install kali-defaults kali-root-login desktop-base kde-plasma-desktop

I fixed this problem in my laptop. I was trying to install Go language support and I have done mistake in setting path so I just removed last changed what I have done using (control+shift+f2) I just typed history and revoke all the last command what I have done in last time....


While at the login screen press Ctrl+Alt+F1 or Ctrl+Alt+F2 to open a terminal. After that type the username and password in terminal.

Now, follow the commands below:

  1. sudo apt-get update

  2. sudo apt-get upgrade

  3. dpkg --configure -a

  4. sudo apt-get install cinnamon-control-center-data

  5. gdm3 --version

  6. apt-get --reinstall install gdm3

  7. apt-get --reinstall install gnome

  8. apt-get --reinstall install gnome-shell

  9. dpkg-reconfigure gdm3

  10. reboot


The solutions of updating and upgrading didn't work for me.

Before shutting down my system I had made some mistake while setting the path for java, so I just edited that file back to previous version from using tty. And since a lot of things got updated(in my case) in this process your desktop feels different so no need to worry.

Edit: press Ctrl + Alt + F1/F2 for accessing tty

  • But how to you access tty if you can't log in?
    – Daniel K
    Jun 6, 2019 at 19:08
  • press Ctrl + Alt + F1/F2 Jun 7, 2019 at 20:47
  • Might be worth adding that to your answer.
    – Daniel K
    Jun 7, 2019 at 23:02

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .