My laptop is an MSI GT70 Dragon edition. Since upgrading to Windows 10, whenever I wake up my laptop and after I enter the password the touchpad will toggle between enabled and disabled, sometimes for over an hour before settling on which it may or may not actually obey. If I use the built in button to enable/disable the touchpad or use the properties menu it does the same thing.

I recently discovered that I can stop the toggling by mashing on the keyboard and during the toggling the keyboard is slow to respond or may not respond at all.

I used the windows feature which searches for drivers, but it says they are up to date and I tried looking for drivers online and didn't find any either. How can I fix this?

Update: I've uninstalled the touchpad drivers and used windows update to install the proper ones as the Windows 8.1 drivers recommended by MSI would not install. This allowed me to enable and disable the touchpad normally, but the multi-touch gestures still wouldn't work. Upon restarting my computer the toggling problem resumed, so that solution didn't work.

  • By using the generic drivers you are indeed going to lose the gestures. There is no solution where those gestures remain enabled and you solve your problem sadly..
    – Ramhound
    Oct 18, 2015 at 1:27

2 Answers 2


The reason this is happening is because MSI has not released Synaptics Touchpad drivers that support Windows 10. The only way you will solve ths problem is by installing the generic Synaptics Touchpad drivers that do support Windows 10.

Windows 10 Synaptics Drives for I2C Devices.

Windows 10 Synaptics Drives for PS2 Devices.

Synaptics Driver Website

Please keep in mind this answer addresses the author's specific problem and does not apply to every situation. The drivers linked to were current when the answer was written and might not be current. Windows 10 reinstalling a newer driver is an entirely different problem.

  • It looks like the PS2 driver worked. The enable/disable button now actually enables/disables properly (at least as well as it did before Windows 10) and the multi-touch gestures work (they didn't with the I2C driver). These fixes still work after restarting the computer, so hopefully they'll be permanent. Thanks. Oct 18, 2015 at 1:16
  • Unfortunately this solution doesn't work anymore: Windows keeps reinstalling the newer (broken) version of the driver everytime you restart (as part of a Windows update) :(
    – Jerem
    Dec 23, 2016 at 10:26
  • Looks like the version you linked is still the most recent available on the website (unless I'm wrong?). But the one windows tries to install on my laptop has a higher version number and it considers it to be an update. Any idea why?
    – Jerem
    Dec 24, 2016 at 8:21
  • Let's keep the comment section clean please. Your own new question don't belong in the comment section
    – Ramhound
    Dec 27, 2016 at 4:04

Manually installing the driver stopped working for me since in early 2016 (I think), because Windows 10 started to install driver updates automatically. But I think I finally found the solution:

How to temporarily prevent a driver update from reinstalling in Windows 10

Basically now there's a "Roll Back Driver" button that fixes it (and if it asks you why you are rolling back, I encourage you to tell them that's because the new version is broken).

Note: In the device manager, the Synaptics driver looks like this (although the name may be slightly different):

enter image description here

So far so good, the broken driver has not been reinstalled against my will.

  • I changed the beginning, is it OK now?
    – Jerem
    Dec 24, 2016 at 8:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .