6

I'm trying to use Cmder (version 1.2) for common tasks on my Windows 7, but I'm having some issues doskey: when I start the Cmder displays this error message:

'doskey' is not recognized as an internal or external command, operable program or batch file.

Executing the doskey command directly from Windows' CLI seems perfectly OK.

How can I fix this?

  • cmder 1.2 is obsolete version. Update it first. – Maximus Oct 18 '15 at 13:06
  • According to the Github repository, 1.2 is the latest version. – ahmed Oct 18 '15 at 13:33
  • There is at least 1.2.9 – Maximus Oct 18 '15 at 17:28
  • Clearing your PATH from outdated stuff can help. – d.raev Jun 16 '16 at 10:36
5

I finally found a solution for this error (and many others I was having with Cmder).

Actually, I just added C:\Windows\System32\ to the PATH.

  1. To do so, rigth-click on the Computer icon (on the Desktop or Start Menu) and choose Properties;
  2. On the top left, click on Advanced system settings;
  3. A small window pops up. Click on Environment Variables... at the bottom;
  4. On the Panel User variables for [your name here] choose the line starting with PATH (generally, the second);
  5. Double click on the value (right part) of aforementioned line or click on edit underneath the panel and be careful NOT to delete its content;
  6. At the very end of the value add a ";" if there is none, then add C:\Windows\System32; (mind the ; and the end);
  7. Click Ok twice to validate the update.

P.S.: You have to restart (close and reopen) your Cmder for these changes to take effect.

That was it!

  • 1
    I hope these steps are clear! – ahmed Dec 5 '15 at 17:31
1

Correct path for doskey.exe should be C:\Windows\System32

Check also if your path does not exceed 2047 characters. When PATH variable is to long paths might not working.

  • the path depends from the Win version, but there is a nice shortcut: %SystemRoot%\system32 – d.raev Jun 16 '16 at 10:35
0

If for any reason you don't have the elevated privileges you can also achieve this using the cmder "Settings" under "Environment".

Steps:

  1. Press Win+Alt+P to open settings.
  2. On the left side of the settings window, under "Startup", select "Environment".
  3. Add this line to the text box

    set PATH=C:\Windows\System32\"

  4. You're all set!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.