0

I recently set up a headless Windows 10 machine to run some shared software that we only have one license for. I want to be able to use remote desktop to connect to it and take control, but I am unable to do so using its APIPA address (169.254.86.113).

I have verified when setting up the machine that the remote desktop services are running on startup and I can connect to it using my home network before bringing the machine to its final location. Where the machine is to be used, there is no other connection option than direct connection via ethernet, and there is not enough desk space to have a monitor and keyboard.

As a side note, I have been able to connect to the machine using its VNC server but I prefer the functionality and speed of RDP.

Any suggestions are greatly appreciated!

  • Why not set up a pair of static IPs on the direct link? – Eugen Rieck Oct 19 '15 at 14:28
  • So something like 10.0.0.1 and 10.0.0.2? I'll give it a shot to see if it'll work. – Brutick Oct 19 '15 at 14:30
  • No dice, RDP still doesn't work with static IPs. Made sure subnet was the same, network level authentication off, VNC works over the static IPs. – Brutick Oct 19 '15 at 14:37
3

If it's Windows 10 Home, it doesn't support RDP as a server--only as a client. See Windows 10 Editions. If it's Windows 10 Pro, it's likely a firewall issue.

  • Like I said in the question, RDP has been verified working on my home network between this machine and my laptop. It is Windows 10 Pro. – Brutick Oct 19 '15 at 14:38
  • 1
    Just fooled around with the Firewall, you were correct. It was a firewall issue between public/private networks. Thanks!! – Brutick Oct 19 '15 at 14:44
1

Contributing on the previous answers:

On Windows 10:

Go to Windows Defender Firewall with Advanced Security and click on Inbound Rules.

Then, find Network Discovery (LLMNR-UDP-In) with the "Domain, Public" profile and enable it. That should do it.

What I don't understand is why Windows assumes it's not on a Private network.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.