1

I have a major texture problem in a game I just installed on my Fedora running on my laptop, and after reading some forums I have came to the conclusion that my system use my "not so powerfull" intel graphic ship instead of the AMD Radeon graphic card I have too.

Here is some of the output of the lspci -v command :

03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mars [Radeon HD 8730M] (rev ff) (prog-if ff)
    !!! Unknown header type 7f
    Kernel driver in use: radeon
    Kernel modules: radeon

00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])
    DeviceName: 32
    Subsystem: Hewlett-Packard Company Device 198f
    Flags: bus master, fast devsel, latency 0, IRQ 51
    Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    I/O ports at 4000 [size=64]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

It seems to me that my Radeon is kind of broken, driver side I suppose (I really don't know much about all of that) since I have this message !!! Unknown header type 7f

What does that mean? And is there a way to force the use of my Radeon? Or even better, tell my system to use it when it need it?

  • Where's the monitor plugged in? – Journeyman Geek Oct 21 '15 at 2:36
  • @Journeyman Geek What do you mean? If you mean where is it physically plugged in: well I am on a laptop so I don't really know. – Roger Oct 21 '15 at 11:55
  • ahh. That its a laptop with 2 graphics options may be worth adding to your question. As would the laptop model. – Journeyman Geek Oct 21 '15 at 11:57
-1

To force the use of your "non-integrated" video card, you should go in your BIOS and either deactivate the integrated Intel graphic card or select the primary card as the PCIE port. This depends on your BIOS and you should be able to find information about this on the manufacturer's website.

  • @pat I checked the BIOS already, I didn't found any way to disable the intel integrated chip. Edit: Can't post the entire lsmod output it is too long, what do you need exactly? – Roger Oct 20 '15 at 16:05
  • The option in the BIOS might be to put the added card as primary not necessarily to disable the integrated one actually. Concerning lsmod, I wanted to check the radeon (or catalyst) module was correctly loaded. – Pierre-Alain TORET Oct 22 '15 at 8:24
  • I haven't saw any think concerning video card in the BIOS, only an option to boost my VRAM (the max was 512), I tried that but it didn't changed a thing. Here is the lsmod output for radeon or AMD amdkfd 94208 1 amd_iommu_v2 20480 1 amdkfd radeon 1605632 1 – Roger Oct 23 '15 at 10:01
  • okay so it seems that it's loaded. have you tried taking the card off ? to see if you have the same result ? – Pierre-Alain TORET Oct 27 '15 at 12:08
  • What do you mean taking the card off? Like physically? I doubt I can do that since it is a laptop but I could try disabling it, but I don't know how to – Roger Oct 27 '15 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.