I installed CUDA toolkit 7.5 from NVIDIA (for Parallel programming course).

But from the very next day, I've observed drastic change in the power consumption. Earlier the battery used to last for around 3.5 hrs to 4.5 hrs which has now diminished to around 1.5 hrs to 1.75 hrs.

I'm not using any graphics oriented program or game or anything that may consume very much power. I'm experiencing the issue even with normal use - browsing and office programs etc.

It's really annoying :(

Does somebody has any solution for this; maybe to temporary disabling the CUDA toolkit and enable it only when I need it (i.e. while programming and running those programs)?

I've Googled with several queries but didn't find anything like my problem.

My laptop is Lenovo Y50-70 with 54760mWh battery and is running windows 10 pro.

  • Stop running the device on battery power when your using running intensive power consuming task like CUDA programs.
    – Ramhound
    Oct 20, 2015 at 14:04
  • I'm not using any power consuming program - no game/graphics oriented program but just normal browsing stuffs. (I should've mentioned that in the thread itself). Even then I can observe the battery percentage decreasing almost every minute! :/
    – Tarun
    Oct 20, 2015 at 14:33
  • If you are not writing or running CUDA applications why do you have the toolkit installed?
    – Ramhound
    Oct 20, 2015 at 15:09
  • I (nobody for that matter) am not writing CUDA programs all the times! I do use it for normal purposes as well - watching tutorials, browsing through websites and stuffs. I don't write and executing programs for long time (afterall I'm learning ). But even if I have to use it for like an hour in the whole day, it doesn't make sense to remove and re-install it again whenever I need it.
    – Tarun
    Oct 20, 2015 at 16:03

1 Answer 1


The toolkit installation has installed a new driver or driver settings which are making some or perhaps all applications default to using the discrete NVIDIA GPU, rather than the built-in Intel graphics on your CPU.

You can change settings back to using the more battery friendly Intel GPU by default from NVIDIA control panel - see here for more details.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .