3

I recently upgraded to Windows 10 and installed WinSCP (imported websites login information from the other computer) and Notepad++ (6.8, previously I used 5.6). I use WinSCP in combination with Notepad++ to edit files on a server that has a very short cutoff grace period for the FTP sessions. WinSCP has persistent FTP session (while NPP, a Notepad++ FTP add-in, seemingly does not) and can be integrated with Notepad++ using the function Edit with...->Notepad++.

Unfortunately, the two are not working well together in Windows 10. Now, after I open the file in Notepad++ from WinSCP, if I switch to WinSCP and then back to Notepad++, I get the following error message:

xxxx file does not exist anymore

Before, this error used to appear when I closed the FTP session in WinSCP before I closed the files that I opened in that session in Notepad++.

I searched the internet but could not find the solution. I tried to change the temporary directory and opened WinSCP admin. I found a thread in the WinSCP forum (http://winscp.net/forum/viewtopic.php?t=9548) regarding another user having the same problem with Notepad++ and WinSCP, but his question remained without an answer.

Update: What I tried to fix the issue.

  • Set the 'Seconds between keepalives' to 15 (defaults is 30 secs): http://winscp.net/eng/docs/ui_login_connection.
  • Authorized Notepad++ to run always with Administrator Permissions.
  • Authorized WinSCP to run always with Administration Permissions.
  • Configured compatibility mode for NotePad++ for Windows 8.1.
2

You have the "External editor opens each file in separate window (process)" editor preference option enabled. That's what causing the problem.

The option is by default unchecked and should be checked only when you use an editor that opens each file in a separate process. That is not the case of Notepad++: When you open the file for editing in WinSCP and the Notepad++ is already running, the new Notepad++ instance just delegates the opening to the existing instance and exits. As you have the above option on, WinSCP detects the exit and considers the file to be closed (deleting it).

For details, see WinSCP documentation for Opening more files in a single editor instance.

| improve this answer | |
  • I had this in the right state already and still didn't work for me, only the suggestion by @Mukund Jalan below helped me. Probably difference in Notepad++ settings, since I have my WinSCP settings fully transferred from another PC where all this works fine for years. – RAM237 Jul 2 '19 at 11:10
  • @RAM237 Did you wanted Notepad++ to open a new window for each edited file? Or is it just a workaround? – Martin Prikryl Jul 2 '19 at 11:57
  • Yes, that works pretty fine for me, I needed this to edit the text file inside the archive, so that I close the window after saving the changes in order to have the archive updated on the remote side. – RAM237 Jul 5 '19 at 11:11
2

You can use "C:\Program Files (x86)\Notepad++\notepad++.exe" -multiInst -nosession !.! as the external editor's path in case you want Notepad++ to open the file in a new window explicitly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.