I'm trying to search for a file in Windows 7 (it's in C:\Users{user}\Application Data...) but when I try to search, it returns the results from a previous search (for the same search term) as soon as I finish typing it, like it's been cached.

I think it didn't show up in the previous search, because C:\ was indexed with this folder (AppData) as an exclusion. The problem is that I have no way of deleting this cached search so it's returning the wrong results.

I tried deleting the item on the dropdown on the search window and deleting the temp files with no luck. I also tried googling but I found nothing. Thanks in advance.


Try deleting and rebuilding the search index:

  1. Go to Control Panel
  2. Select Indexing Options
  3. Click on Advanced (this will open the Advanced Options dialog)
  4. Select the Rebuild button.

If that doesn't work try choosing a new location for the index, just below the Rebuild button.

  • Thank you very much, I didn't reply before because I was waiting for it to finish rebuilding (it took a LONG time, and it was just a clean partition with Windows and nothing else). It found the new files, but I'm worried if it'll find any files that are created after that, because the results are instant like before. Thanks!
    – user25668
    Jan 22 '10 at 17:28
  • If you have viewing by category, indexing options can be found in: System and Security > System > Performance Information and Tools. Or you can run control.exe srchadmin.dll command.
    – mirh
    Aug 23 '19 at 20:39

Rebuilding the index can be a very long process. I recommend, if possible, to remove and add to the index, the specific directory you are searching in.


Are you searching by file name or contents? If rebuilding the index doesn't work as Ryan suggested (it should), you may be interested in Everything from voidtools. It can quickly index your hard drive so you can find files fast:

alt text

  • Thank you very much, it worked, but as I said before, I don't know what will happen when I try to search something that wasn't there when I rebuilt the cache, I guess I'll have to test it. If it doesn't work, I'll check that out, it looks very promising, thank you very much!
    – user25668
    Jan 22 '10 at 17:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy