38

With Windows 7 (and XP) I could walk up to a locked PC (without Ctrl-Alt-Del requirement) and start typing my password, even with the screen off, and the keypresses would all be sent to the password field, meaning that by the time the screen was on I was at the desktop.

Same hardware, same scenario, but with Windows 10 it seems I have to press a key/mouse button, wait for a second or two before the password field is 'ready' before I can start to type the password.

This is annoying after many years of being able to unlock a PC in the same, quick way.

I've looked through the mish-mash of new Windows 10 and legacy option dialogs but can't seem to find anything that might affect this behaviour.

Is there any way round it?

  • I have found no way to change the new behavior, Microsoft has adopted the "our way or the highway" mentality starting with W8. – Moab Oct 21 '15 at 20:31
  • 1
    Sounds about the way things are, do you have any source for it though? – Lunatik Oct 22 '15 at 14:12
  • 1
    as per a previous question/rant - my pc is not a phone - lockscreens on non touch screen devices is dumb. – Journeyman Geek Oct 28 '15 at 1:16
  • A USB hub was the problem in my case: superuser.com/a/1444918/74576 – Ryan Jun 4 at 17:20
21
+50

You can do it, here's how:

1 - Turn off the Lock Screen

This does NOT unlock the computer, it just takes you straight to the password field instead of making you swipe an image away.

  • In Group Policy Editor, Enable the policy at Computer Configuration >> Administrative Templates >> Control Panel >> Personalization >> Do not display the lock screen.

    (detailed instructions in the answer to this SuperUser question).

2 - Enable Screensaver Logon Screen but NO Screensaver

  • Search for "Change Screen Saver" to open "Screen Saver Settings".

  • Check the box labeled "On resume, display logon screen".

  • In the "Wait:" field, choose how long you want to wait before locking the screen.

  • DO NOT choose a screensaver, or you'll have a short delay before the lock screen appears

Screensaver Settings

3 - Create a Power Plan to Turn off Display but NOT Sleep

  • Search for "Choose a Power Plan" to open "Power Options"

  • Choose a power plan and select "Change plan settings" OR click "create a power plan" in the left sidebar.

  • Select a time for "Turn off the display"

  • DO NOT set a sleep time - if you do, you'll have to wait for the computer to wake up before seeing the lock screen

Power Options

  • Excellent! Thank you, it was the group policy setting I was missing. They sure don't make these things easy... – Lunatik Oct 29 '15 at 19:18
  • 2
    Note: Gpedit is only available in w10 pro or higher versions. – Moab Nov 21 '15 at 21:53
  • 4
    does anyone have a solution to keep both the swip-away lockscreen AND have the password box to receive focus and allow input immediately? Or somewhere to report this to microsoft? I mean really... – stvn Jan 18 '16 at 17:28
  • 4
    Regarding point 1., if you don't have a Group Policy Editor, you can get rid of the "swipe away" lock screen using a simple registry hack. Under key HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Personalization add or change DWORD called NoLockScreen to the value 1. – ADTC Aug 7 '16 at 5:25
  • For Windows 10 there isn't any "Do not display the lock screen" in the group policy – John Henckel 6 hours ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.