2

I've been pulling my hair too long for this particular problem and now I'm on the verge giving up.

Scenario: local network in the workshop consisting of two Linux-machines (one server, one workstation), two Android-phones, one Windows 7 (my workstation) and another Windows 7 (customer's computer). The customer's computer is the culprit, so I'll refer it as "W7" from now on.

All devices can connect to the internet without problems, except W7.

W7 can resolve addresses in cmd (nslookup www.google.com gives correct result). W7 can ping www.google.com as well as 192.168.1.1 (router). W7 can also connect to the internal Samba-shares, either by IP or by Samba-name.

But W7 can not access www.google.com in a web browser. Tried both Internet Explorer and Chome, none of them can access any web page. This had me think of something that blocks or proxies port 80, so I have turned off antivirus (Avira), firewall (Windows Firewall) and Windows Defender. Still, no go on port 80.

My Windows 7-workstation has no problems at all, so this error seems to be internal to W7 somehow but I have no idea how to track this error.

How can I find the culprit that filters / blocks port 80 on W7?

EDIT: I just tried telnet 192.168.1.1 80 and typing GET / gives me the router's login-page. That is, telnetting to a web page works, but not using a web browser.

EDIT 2: Telnet also works for www.google.com:80.

EDIT 3: Checked IE, Firefox and Chrome proxy settings. All are clean ("do not use proxy") but still can't connect using a web browser. Windows Update works (can check for updates and download), Skype can login (but not show "skype homepage"), Steam cannot login. Something has obviously hooked something in the system, but Defender and MalwareBytes says everything is clean.

3
  • First, port 80 is the destination port; your local outgoing port will be different so it's useless to check for any local port 80 settings (machine or network infrastructure). Second, the conclusion from your test is invalid: Just because you can telnet the router on port 80 doesn't mean you can telnet google.com on port 80.
    – Run CMD
    Oct 21, 2015 at 8:17
  • Fair point. I just retried telnet with www.google.com and it works like a charm.
    – bos
    Oct 21, 2015 at 9:36
  • What exactly is the error message in the browser? Since the problem is only in web browser(s) have you tried "safe mode", incognito, running without plugins, etc.?
    – qasdfdsaq
    Oct 21, 2015 at 12:10

2 Answers 2

1

IE and Chrome use the same internet settings for proxies. Have you checked the proxy settings in the internet settings dialog?

Chrome

  1. Menu icon
  2. Advanced settings
  3. Change proxy settings
  4. LAN Settings

IE

  1. Settings Cog
  2. Internet Options
  3. Connections
  4. LAN Settings

If there is a proxy set up it will be listed here and you can add or remove proxies in the advanced dialog.

How to open the LAN proxy settings in Chrome

Other Options

I've been thinking about this since I originally answered and remembered that Firefox uses a different system for registering and using proxies. You could install it on a pendrive to test the theory and see if that can access the web.

0

Many hours later the culprit was found: a hook was made into a dll-file that processed www-data to/from browsers. That's why telnet on outgoing port 80 worked, but not the standard browsers.

The program ADWCleaner found this, while Avira, Defender and Malwarebytes were all unable to.

Everything is now working like a charm.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.