9

I recently upgraded Office from 2010 to 2013. I have a large (700 pages) and complex document that contains text and pictures (inserted as In-Line With Text). The document has two problems:

1) Pictures are no longer visible in Word 2013. I noticed that if I change the view from Web Layout (which is the most suitable view for this particular document) to Print Layout, then the pictures become visible. The following workarounds did not help: - Changing the position/wrapping of the pictures (which are clickable elements, if all white) - using the "convert to latest document format"option (the document is right now in 2013 docx format)

2) In addition, Word reacts very slowly when I edit this document; all actions are very sluggish, with a delay of about 2 seconds, which is frustrating. The following are causes that I've ruled out, or workarounds that don't help for this problem:

  • PC performance: same problems affect this doc when opened on other PCs, with other Windows and Word versions
  • deleting contents from it till the document remains very small doesn't help
  • copy and paste everything into a new document doesn't help
  • save as another document (still docx format, or word 2003 DOC format; maitaining compatibility or not) doesn't help

The only workarounds that help (speed of operation becomes normal) are: - deleting most of the contents of the document reduces the sluggishness - viewing the document in Print Layout somewhat reduces the sluggishness

Any suggestions what I can try to get rid of these 2 problems - which seem to be related - for my document?

  • Have you tried Openoffice/Libreoffice? – DavidPostill Oct 21 '15 at 15:55
  • 2
    Yes but I would like to keep using this document with Word 2013 in this case – z8080 Oct 21 '15 at 15:58
  • Just for interest then, was it more responsive? – DavidPostill Oct 21 '15 at 15:59
  • I haven't opened this particular document in OO after it became corrupted, and no longer have OO installed – z8080 Oct 22 '15 at 9:11
  • 1
    Just to complete the point: as this document still has this problem, I had another go today at trying smth new to fix it. Having installed Libre Office and opened it there, the performance is no better than in Word, in fact LO even crashes after this document has been opened for a while. Seems like what I need is to somehow "de-corrupt" this document, as I have tried absolutely everything I could think of. – z8080 Apr 12 '16 at 15:11
1

I too had this problem with a large document - Word 2013 was sluggish and not displaying pictures in web layout. The document was about 8 MB and 900 pages.

After some investigation I concluded this is a deficiency in Word's rendering of web layout.

For the record:

  1. Various of ways of 'tidying up' the document had no effect (saving to rtf format and opening the rtf file; opening and saving in LibreOffice as docx and opening the docx file; repeating but using odt format; copying without the final pargraph mark; etc)
  2. LibreOffice, although sluggish, was able to render the document in web layout
  3. Using the old doc format allowed Word to render OK
  4. Images display correctly near the start of the document
  5. Splitting the document into subdocuments and a master shows the same problem

The clincher for me was discovering that the same picture inserted at successive locations rendered squashed up and then not at all. Here's a screenshot from the place in the document where things go wrong.

enter image description here

So there is a point in the document beyond which images do not render, as though a limit has been reached and an attempt is made to render the image by squashing it vertically. The limit varies with the pane size for displaying the document e.g. if the navigation pane is displayed the limit on image displaying is moved up the document.

This is a bug in Word's image rendering in Web Layout of the later file format.

In my case, since I wanted to use Word rather than switch to LibreOffice, and use docx rather than doc format, I split the document into several separate smaller documents; these display images OK although are a little inconvenient.

  • Many thanks for your input, this does seem to be the same bug. And splitting is the (very suboptimal) workaround that I went with in the end also! – z8080 Oct 15 '18 at 14:44
7
+50

The long thread Word 2013: Extremely slow saving and pasting plain text in long documents, from January 2013, contains some workarounds that worked for some people.

Here is the list. I suggest to try them one-by-one and undo the ones that do not help:

  1. Save As in "Word 97-2003 Document (*.doc)" format
  2. Save the document in RTF file format, open a new Word 2013 document and import the RTF file, then save in Word 2013 format
  3. Disable hardware acceleration in "Advanced settings"
  4. Disable "Allow Background saves" (some people report that enabling Always create a backup on save also helps)
  5. Turn off Background Repagination
  6. Reduce the size of included pictures
  7. Break apart the document and only rejoin the pieces when printing.
    See these references for master-subdocuments in Word :
    1. Understanding Master and Subdocuments
    2. Creating a Master Document Using Existing Subdocuments
  8. Check add-ins in File / Options / Add-ins / Manage / COM Add-ins, and disable the ones you don't use. You can launch Winword with the parameter /safe to work without any add-in.
  9. Change the default printer to a virtual PDF printer
  10. Copy-paste the document to a new Word 2013 document
  11. Disable "Spelling and Grammar Check"
  12. Upgrade to Office 2016
  13. Get a faster computer with more memory

The article 10 Microsoft Word 2013 headaches and how to cure them might also be useful.

  • 2
    The 10 tips were just for your information. I think that my list above is quite exhaustive, so as far as I can see, your options are : 1) Go back to 2010 (to be honest, I don't see a big difference in functionality between it and 2013, whatever Microsoft says), or (2) Upgrade to 2016 in the hope that the bug is really fixed as reported, or (3) Wait of course for a better answer (which you should do in any case, at least for the duration of the bounty), or (4) Try a free alternative to Office such as LibreOffice. These are all the ideas I can think of. – harrymc Nov 1 '15 at 16:43
  • Just as an update: Office 2016 renders this document in the same sluggish way, and copying/pasting into a new Word 2016/2013/2010 document does not help, even when done chapter by chapter. Same for Word 2010. Opening it in LibreOffice does not either. I do need to keep extending this document and I am at my wit's end as to how I can get it to be more responsive, other than the workaround I observed of keeping it in Print (rather than Web) view, which given the layout of this document, is severely suboptimal – z8080 Apr 12 '16 at 15:18
  • 1
    I have added more advice : points 5-9 & 13 above. There are also other free alternatives to Word which have a good reputation : Kingsoft and SoftMaker (but which I never tried personally). See also these tips. – harrymc Apr 12 '16 at 18:00
  • you are amazing, thanks so much :) i'm afraid i've already tried all of these, except for 6. which I can't do much about as the doc does contain lots of information including pictures. – z8080 Apr 12 '16 at 20:48
  • 1
    I see you are a very advanced user of Word. I think that if you can't find out why Word is slow only for this document and only on your computer(s), you could use a mix between Word and another editor, depending on the kind of editing. – harrymc Apr 19 '16 at 10:29
0
  1. Open the .docx with Libre Office writer
  2. Click on File/Save as and in the drop down Save as type choose the .docx format.
  3. In the alert, choose Use Office Open XML Text Format (do not choose ODF Format).
  4. Open the .docx in MS Word.
  5. If necessary, reapply your template: File/Options/Add-Ins in the drop-down Manage (bottom), select Templates and Go. Then choose your templates, check Automatically update document styles and click Ok
  6. If necessary, reapply the style to the footnote references : in the style ribbon, right click on Footnote Reference and click on Select All, wait for MS Word to select all your footnote references and then click on the Footnoote Reference style (this reapply the style to all the footnore references).
  7. If necessary, do step 6 but with Endnote Reference

This works because Libre Office Writer cleans the code of the .docx

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.