My Skype is working almost completely. I can send files, make and receive calls and chats normally. However, I don't receive messages from chat groups that have been created recently.

What I have tried:

  1. remove my ~/.Skype folder;
  2. reinstall another version from ubuntu repositories (32 and 64 bits);
  3. firewall rules;
  4. proxy is fine as other users are successfully talking.

I am on Ubuntu 14.04 64 bits and Skype 4.3.0.37-1 32 bits but this problem seems to happen even on Windows (here and here)

It seems to be related to cloud group chats.

I don't receive messages from groups whose name starts with "19:xxxx". However I receive from groups whose name starts with $ or something else.

The following command returns the group name:

/get name
up vote 38 down vote accepted

I will answer my own question... I hope this will help someone! :)

After struggling a bit, I found some useful commands:

  • /dumpmsnp - show details about your connection
  • /showplaces - show where you are currently connected

You can execute them in any chat window.

/dumpmsnp command was showing "LoggedOut", but I was online and talking almost normally (except group chats).

System: MSNP: Connection Data:
 * Status: LoggedOut

A lot of people are/were suffering from this problem (here).

To solve this "LoggedOut" issue, try this on any chat window:

/msnp24

and restart your Skype.

After restarting, /dumpmsnp output shows the following status:

System: MSNP: Connection Data (MSNP24):
 * Status: LoggedIn

I don't know exactly why, but the /msnp24 command kinds of converted my account to this protocol and now everything works perfectly.

I've found the solution here.

  • Awesome!!! Magical!! take a bow!!! – Kishor Pawar Mar 22 '16 at 10:15
  • This solved my problem! Thank you! – aserww106 Apr 28 '16 at 18:21
  • This solved so many headaches. Thank you!! – Hydra IO Jun 30 '16 at 17:53
  • 2
    Confirmed works. You need to make sure there are no spaces after the command. Thanks!! – Jus12 Dec 14 '16 at 9:38
  • This is absolutely amazing! I've been struggling with this soo much. Thank you!!! – TheFallen Jan 31 '17 at 11:37

/msnp24 doesn't works for me, but problem solved.

If you vi ~/.Skype/<your_skype_username>/config.xml, then navigate to the HomeServer tags, you will see something similar to:

<MSNPCore>
  <HomeServer>BAYMSGR2013521.gateway.messenger.live.com</HomeServer>
  <NewThreadAllowed>1</NewThreadAllowed>
  <P2PMigrationAllowed>0</P2PMigrationAllowed>
  <ProtocolToUse>24</ProtocolToUse>

Now test this HomeServer's hostname with traceroute command, e.g. traceroute BAYMSGR2013521.gateway.messenger.live.com above, the last line will got to *** which might because of firewall blocking. So just:

  1. Ensure you close any running skype instance(check by ps aux and kill -9 skype_PID).
  2. Delete the HomeServer tags in config.xml. Either empty the tags or delete the line should works. Save the file.
  3. Start the skype. It should able to send and receive group chat messages now.
  4. Check config.xml again, the tags should automatically updated with new hostname.
  5. If you test this new hostname with traceroute, it should go to last line which are not ***.
  • Thanks for improving even more this issue. It can be an alternative for someone else. – Bruno Oct 23 '15 at 16:37
  • I combined this answer with the previous one and it worked perfectly for me! I avoided clearing my Skype chat. – StockBreak Nov 24 '15 at 14:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.