2

MacBook Pro, Yosemite 10.10, 64-bit, 4 GB RAM, 100 GB free on HD.

  1. Have downloaded VirtualBox 5.0.8.dmg and kali-linux-2.0-amd64.iso
  2. Double-clicked the dmg to install VBox and all goes well with "New" and "Settings", etc.
  3. Link "Storage" to the iso file
  4. Press "Start" and get a "Critical Error" message with no details as to what that critical error is.

I never get to the window that says "Kali Linux" and then (if I remember), it's something like "Graphical Install". Never even get there.

I'm no expert at this but I'm about 99% sure all Settings are OK. I've tried a complete uninstall, downloading the files all over again, and reinstall with the same problem.

Any tips as to what might be wrong here?

1

Download your ISO from Offensive Security Page, they have built special images for installing kali on Virtual Machines.

I had similar problems getting the normal ISO to install on Virtual Box, but then tried that link and didn't have a problem.

Only thing I remember having to check was the Virtual Disk size. It needs to more than 12GB for some reason. My Virtual Box install of Kali on this computer has a 30GB disk, and almost 9GB is used.

Hope that helps.

1
  • Thanks heaps for that. Downloaded from offensive security and it worked. The only added thing was that the file was in .ova format and I sure didn't know what to do with that, but a little digging produced the solution: In VBox > File > Import Appliance. Worked like a charm. I'm up and running. – Chris Swift Oct 24 '15 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.