1

Suddenly after updating Chrome (from v36 => v41 I think) I started having persistent DNS resolution errors in Chrome. Eventually after using Chrome for an indeterminate amount of time, when I try to visit an HTTP(S) URL Chrome will Display:

(In viewport:)

This webpage is not available

ERR_NAME_NOT_RESOLVED

(In console:)

net::ERR_NAME_NOT_RESOLVED

(In chrome://net-internals/#dns:)

error: -105 (ERR_NAME_NOT_RESOLVED)

The requests show up in Developer tools > Network as status: (failed).

Sometimes after displaying the error, sometime later it automatically "refreshes" and actually loads the page. Me refreshing the page multiple times sometimes gets it to load, but eventually becomes useless. At least sometimes it'll work fine for a while after being restarted, before eventually becoming unusable due to the errors. However, even after the problem has started it's intermittent: some requests still work after others haven't, with no apparent rhyme or reason. Onset of the error is perhaps linked to the number of windows / tabs that are open or the length of time Chrome has been running.

I suspect that Chrome may be exhausting some internal resource of which it's allocated an abritrarily low amount.

Premise

  • Chrome 41-45 Win 7 x64 ("installed" via PortableApps, in case it matters).
  • Prefetch resources to load pages more quickly / Predict network actions to improve page load performance was & is disabled
  • Windows' DNS Client service (Dnscache) is stopped & disabled.
  • There's no persistent antivirus running.
  • Windows Firewall is running and has always been configured to allow Chrome access.
  • When the problem happens in Chrome, other applications such as Firefox work with no problem. (I'm posting this with Firefox right now because Chrome refuses to load the site.)
  • There's no proxy running (normally, see below).
  • On chrome://net-internals/#dns, under Async DNS Configuration, there's Internal DNS client enabled: false. Clicking Host resolver cache Clear host cache doesn't help.
  • None of the following had any effect:
    • Running in incognito mode with no extensions enabled.
    • Disabling hardware acceleration
    • Clearing cookies.
    • Creating and running under a new profile with no extensions except the defaults.
    • Resetting Chrome's settings.
    • Uninstalling and reinstalling (such as it is via PortableApps).

Proxy (Fiddler2)

This point is so special that I want to single it out: Running Fiddler2 (HTTP debugging proxy) and proxying Chrome through it eliminates the problem while Fiddler2 is running.

Questions

  1. What could cause this problem?
  2. What can be done about it?
  3. What could explain the problem going away when proxying Chrome through Fiddler2?
  • Where is Fiddler running? Have you tried (wireshark) tracing the DNS requests sent by Chrome? – qasdfdsaq Oct 26 '15 at 14:25
  • @qasdfdsaq Where? Locally, in the same Windows 7 instance. Is that what you mean? I haven't tried wireshark. I originally ran Fiddler2 in relation to this problem to see if it would provide any information that could help me debug the problem (though I figured it probably wouldn't, since it's an HTTP proxy -- I don't think it touches DNS). I was very surprised to find that running it cures the problem (while it's running), which I'm sure reveals something important, but that I don't understand. If the "answer" doesn't emerge here, I suppose I'll try wireshark (or equivalent) next. – JMM Oct 26 '15 at 14:35
  • When using a proxy the browser doesn't send DNS requests itself, it sends the request to the proxy and the proxy does the DNS resolution (usually). I suspect Chrome is sending them in a certain way that's confusing your DNS server – qasdfdsaq Oct 26 '15 at 14:52
  • @qasdfdsaq Hmm, well as noted Chrome works fine for a while, then at some point decides it's not going to resolve DNS queries anymore. – JMM Oct 26 '15 at 15:12
  • Try to change your DNS servers to google : In the network adapter's Properties set the preferred and alternate DNS servers to 8.8.8.8 and 8.8.4.4 and reboot. Have you tried to power-cycle your router? – harrymc Oct 26 '15 at 18:28
0

The answer can be briefed as follows :

How does fiddler work in chrome :

enter image description here

If you notice the proxy setting while using fiddler ,it would be set as <loopback>

Now getting back to the problem :

Your settings would depend upon the internal browser settings,mostly it would depend upon the ie or firefox

1) flush and renew your DNS, you can do this with msprompt:

net stop dnscache
net start dnscache
ipconfig /flushdns
ipconfig /renew
ipconfig /registerdns

Now as you have mentioned that Windows DNS Client service (Dnscache) is stopped & disabled,Inorder to mitgate this try to start the DNS service as mentioned over here

Alternatively you could try to Repair/Reset Winsock settings using this command:

netsh winsock reset catalog

the above command will reset the catalog and you’ll need to restart your computer.you can check/see the data saved in DNS Cache through following command :

ipconfig /displaydns

Another solution might be ensure you have checked "Use the following DNS server addresses" and you could use the following dns

Preferred:  8 . 8 . 4 . 4
Alternate:   8 . 8 . 8 . 8
Check  "OK"

Ensure you doesnt use ipv6 if you use IPV6 address ,make sure that DNS is set back to automatic and IPv6 has been disabled.

Also you didnt mentioned about whether your ie or firefox working fine ,the last solution would be resetting chrome to defaults and import settings from default browser[ie/firefox]

if all the above solutions doesnt work ,do the following and edit the question : Re-enable the windows firewall connect to the router/modem per usual get a command prompt (start->run->cmd) and enter ipconfig /all >test.txt now copy the entire contents of test.txt

  • I'm sorry, but that makes no sense: why would I re-enable the Windows DNS cache just to then clear it? Setting my DNS servers to Google's is not an option. I did mention that Firefox and other HTTP applications work with no problem after Chrome stops working. – JMM Nov 4 '15 at 16:50
-1

Try to flush and renew your DNS, you can do this with msprompt:

ipconfig /flushdns
ipconfig /renew
ipconfig /registerdns

Other methods I'm seeing are adding DNS addresses manually and restarting your modem for 5 minutes.

  • Thanks for the suggestion, but "Windows' DNS Client service (Dnscache) is stopped & disabled." – JMM Oct 26 '15 at 14:18
  • Ah, right, totally wasn't paying attention to that part lol – GalacticGhost Oct 26 '15 at 14:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.