0

I'm getting this HUGE message every single time I save an angular template (which is saved as a .html file):

|1 col 1| Warning: missing <!DOCTYPE> declaration
|1 col 1| Warning: inserting missing 'title' element
|| Info: Document content looks like HTML 4.01 Strict
|| Info: No system identifier in emitted doctype
|| 2 warnings, 0 errors were found!
|| 
|| 
|| To learn more about HTML Tidy see http://tidy.sourceforge.net
|| Please send bug reports to html-tidy@w3.org
|| HTML and CSS specifications are available from http://www.w3.org/
|| Lobby your company to join W3C, see http://www.w3.org/Consortium

How can I disable it?

2
  • How can I tell? :( – Erik Escobedo Oct 23 '15 at 0:04
  • There's no such line at all. I double checked. – Erik Escobedo Oct 23 '15 at 0:29
1

It looks like you have something nonstandard in your vim installation or profile that invokes the external utility htmltidy when you save a file. This doesn't seem to be normal/standard.

See Cleanup your HTML for a variety of methods by which this sort of thing can be done.

I would use the command :scriptnames to list which configuration files are loaded by vim and then scrutinize each of them for htmltidy.

You may have a file named html.vim in a location searched by vim at startup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.