1

Every time I try to use apt-get install or remove or purge I have this error pop up:

The following packages have unmet dependencies:
 libimage-magick-q16-perl : Depends: libmagickcore-6.q16-2 (>= 8:6.8.9.9) but it is not going to be installed
 libmagick++-6.q16-5 : Depends: libmagickcore-6.q16-2 (>= 8:6.8.9.9) but it is not going to be installed
                       Depends: libmagickwand-6.q16-2 (>= 8:6.8.8.9) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Then I go and run 'apt-get -f install' to try to fix it and I get another error:

nichadler@debian-server:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libatkmm-1.6-1 libcairomm-1.0-1 libglibmm-2.4-1c2a libgtkmm-2.4-1c2a
  libgtkspell0 libimage-magick-perl libimage-magick-q8-perl libpangomm-1.4-1
  perlmagick ttf-dejavu-core
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  libimage-magick-perl libimage-magick-q8-perl
Suggested packages:
  imagemagick-doc
The following packages will be REMOVED:
  libimage-magick-q16-perl libmagick++-6.q16-5 libpstoedit0c2a pstoedit
The following NEW packages will be installed:
  libimage-magick-q8-perl
The following packages will be upgraded:
  libimage-magick-perl
1 upgraded, 1 newly installed, 4 to remove and 19 not upgraded.
Need to get 0 B/397 kB of archives.
After this operation, 2,540 kB disk space will be freed.
Do you want to continue? [Y/n] y
Reading changelogs... Done
(Reading database ... 148618 files and directories currently installed.)
Preparing to unpack .../libimage-magick-q8-perl_8%3a6.9.1-2_amd64.deb ...
Unpacking libimage-magick-q8-perl (8:6.9.1-2) ...
dpkg: error processing archive /var/cache/apt/archives/libimage-magick-q8-perl_8%3a6.9.1-2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/x86_64-linux-gnu/perl5/5.20/auto/Image/Magick/Magick.so', which is also in package libimage-magick-q16-perl 8:6.8.9.9-5
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for man-db (2.7.0.2-5) ...
Errors were encountered while processing:
 /var/cache/apt/archives/libimage-magick-q8-perl_8%3a6.9.1-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any help?

1
  • Have you tried following the solution proposed by apt-get -f install, step by step? In other words, first do an autoremove. Then remove the packages libimage-magick-q16-perl libmagick++-6.q16-5 libpstoedit0c2a pstoedit, then do an update and upgrade, then finally install the package ` libimage-magick-q8-perl`? Oct 25, 2015 at 8:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.