0

I am using a TP-LINK WN727N Wi-Fi adapter. After I upgrade to Windows 10, every time I tried to connect it goes to verifying and connecting. It’s stuck there. No Internet for me.

My problem is similar to what is described here.

I changed the driver. I installed a bunch of drivers. Still fails.

I also tried the solution explained here and it doesn’t work. It says no such key:

The system was unable to find the specified registry key or value

Usually after a while no Wi-Fi is shown at all.

  • Try resetting the ip stack. Run the following commands in a cmd shell: netsh int ip reset, then netsh winsock reset and finally netsh advfirewall reset – DavidPostill Oct 25 '15 at 10:16
1

According to this page, your adapter should be compatible with Windows 10. If you've already tried reinstalling the driver, the most likely problems are (1) something wrong with your operating system or (2) there's something wrong with the adapter's hardware.

It will be easiest to first investigate the adapter. Try using that adapter with another computer, or using another adapter with that computer. If you don't have one, you can buy one from a store like Best Buy - if it doesn't help, you can always return it.

If another adapter has the same problem on this computer, or if this adapter works on another computer, there is likely something wrong with the operating system. You may get lucky and find a quick fix like the registry change you linked to, but ultimately, you may need to reinstall Windows 10.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.