25

In Windows 10, how do you disable the high volume hearing loss warning dialog when attempting to increase the volume above the level of 42?

high volume hearing loss warning dialog

I do not want to see this warning when plugging in my external speakers, obviously because it does not apply.

5
  • 18
    Dumbest thing since the EU cookie law?
    – RomanSt
    Apr 16, 2016 at 13:50
  • 1
    If this helps towards a solution, I get this impression this might be a Samsung-only issue?
    – enigma
    May 7, 2016 at 20:56
  • Yes, Samsung is accountable for their own laptop designs, and they did the blunder of integrating the RealTek audio system. This pack of drivers contains the dumbest thing ever. Sorry to say, but my trust in "far east" software is subject to a cold chill. This misinterpretation of EU regulations is just too stupid to pass any ordinary quality control in the west. It is not possible to discuss this issue with Samsung, nor with Realtek. See noach.one noach.one/technotip/idiotic-realtek-audio-drivers TIP:Revert to original Microsoft audio drivers, working perfectly. Problem solved.
    – carl
    Jun 20, 2016 at 14:09
  • am I the only one want this warning when headphone is plugged? I have self-built desktop and don't think realtek panel has option for this. Oct 18, 2016 at 14:48
  • And this is why regulations are very short sighted and so often causes a negative sum total benefit rather than positive. It's fundamentally the same as stereotyping. This may help some, so that's good right? it can't be negative to more people! this policy isn't myopic at all!
    – ahnbizcad
    Oct 22, 2018 at 3:12

10 Answers 10

10

This appears to have been fixed in the latest version of Realtek Audio Console. Under Playback Devices -> Headphones there is now a toggle for "Ear Protection." See highlighted part of screenshot below:

disable volume warning

1
  • 1
    god bless your soul
    – ahnbizcad
    Mar 19, 2020 at 19:53
7
+50

I do not want to see this warning when plugging in my external speakers

According to this blog entry Idiotic Realtek audio drivers on Windows 10, the only solution is to permanently remove the Realtek drivers.

See the instructions below.


How to remove the Realtek audio drivers

The traditional and normal removal of drivers, from device manager, does not work with these audio drivers that behaves and cling on to your computer like a virus.

To permanently remove them:

  1. End all Realtek processes using Windows Task Manager.
  2. Uninstall the driver under Device Manager / Sound, Video and Game Controllers. Select also the "deleted driver files" if this option becomes available. (It will not help to remove the drivers this way, because the Realtek driver system do not obey standard Windows rules for driver management)
  3. DO NOT restart yet!
  4. Instead, enter C:\Program Files and locate the Realtek folder. In the properties of this folder, make sure SYSTEM is completely disallowed to do anything on that folder. This will prevent a reinstall after reboot since SYSTEM will be unable to change anything in the folder.
  5. Reboot.
  6. If the Speakers are missing its drivers, they now have the yellow warning sign. Click Update Drivers from properties, and make sure new drivers are selected by (1) Browse computer (2) Let me pick…
  7. DO NOT select the Realtek drivers that was not deleted even if it was specified in 2, but select the standard Windows device drivers, called High Definition Audio Device.
  8. These drivers will work just like audio drivers on Window always work, problem-free, and you will have no more problems with the bulky far-east kindergarten audio software from Realtek.
  9. Please send a polite request to Realtek and kindly ask them to look into this matter. It is a funny thing that we have been doing this for years with no reaction. Their email should be: pctech@realtek.com

Source Idiotic Realtek audio drivers on Windows 10

3
  • 3
    This solution works (thanks!). To future answerers: I'm hoping to be able to keep the RealTek drivers.
    – enigma
    May 8, 2016 at 10:03
  • You might be able to just rollback the RealTek driver to a previous version that didn't (mis)use the new Windows 8/10 API.
    – harrymc
    May 8, 2016 at 10:39
  • seriously. I linked realtek to this Q/A in an email outlining how stupid their code/setting/policy is from a UX standpoint, and so much so that it not only chases away customers but how severe it is that it hurts their brand.
    – ahnbizcad
    Oct 22, 2018 at 3:06
5

This seemed to work for me:

  1. Have the speakers plugged in.
  2. Go to "Manage Audio Devices."
  3. Double-click on the "Headphones" (speakers).
  4. Select "Custom."
  5. Uncheck "Ear Protection."
1
  • It's very simples and works! Thanks you, thanks lord! Feb 6, 2020 at 21:34
1

If you have Realtek, open the Realtek Audio Manager, click on the 'i' icon in the bottom right, de-select the 'Display icon in the notification area' and click OK. Reboot to test if this helps.

image

5
  • 2
    Nah, that doesn't work. Thanks for trying though.
    – enigma
    May 8, 2016 at 10:01
  • 2
    Oh, ugh. That "Display icon in notification area" is a checkbox? It's so round, it looks like a radio button.
    – TOOGAM
    May 8, 2016 at 10:16
  • try your solutions before posting.
    – ahnbizcad
    Mar 19, 2020 at 19:46
  • @ahnbizcad: You did notice that now it's the year 2020 and this answer was posted on 2016?
    – harrymc
    Mar 19, 2020 at 20:02
  • you did notice there is no expiration or change warning that anyone can know beforehand? you can post a solution and the very next week an update might kick in. and why would displaying an icon in notification area solve the original problem?
    – ahnbizcad
    Mar 21, 2020 at 1:31
0

QUICK (BUT FATAL) UPDATE:

The message and problem got back on the next restart...

Customer support told me it is not possible to remove the message...

I'll keep looking.

Sorry.


Original answer:

I had the same problem till this afternoon. I updated the audio driver and the message is gone. Some research indicates it is a Samsung thing...

Anyway, how I did it:

Went to Device Manager by searching Device Manager on the task bar;

I opened the Sound, video and game controllers option;

Right-clicked Realtek High Definition Audio;

Clicked Update Driver Software...

It did the trick for me, so far...

I found solutions mentioning uninstall the driver and reset the machine. I thought updating would be similar so I did it and it seems to have worked.

0
0

I have a Samsun spin 740U3m which I bought from best buy in July 2017. I found I could install the microsoft driver without changes to the realtek directories.

Photo: where to make the change

One of the options is the MS drivers. It warned me that they might not work, but I accepted them anyway.

When i was finished it looked like this:

      Photo: end result

This survived a reboot. The MS driver is very basic, but at least it works without this horrible problem.

1
  • I've found that on my older Windows 10 laptop that replacing the Realtek drivers with Microsoft's own does seem to reduce the CPU usage when playing audio. The only problem with these drivers on laptops however is that the on-board speakers and headphone jack will no longer be a combined audio output; there are some applications (like Final Fantasy 14) that don't handle switching audio devices on the fly very well, which can happen when you remove your headphones. Nov 15, 2017 at 13:36
0

I had the same problem. But I've already installed additional drivers for my KORG keyboards. So I just disabled Realtek drivers by changing the folder C:\Program Files\Realtek name to C:\Program Files\Realtek.2del and after the restart of the computer I just deleted this folder. Now it's working properly on my computer. In my opinion you can just TRY my way having other sound drivers on your computers.

0
-1

I have a solution to make infinity less annoying. Bear in mind I am not tech savvy, but this problem annoyed me so hears what I found out. The core of problem is that to save power your software will pause the driver in control of the headphones, so every time they turn off and then audio goes through them again, you will get another notification.

Solution for those who don't want to read to much.

  • Go to Device Manager
  • Sound, video and game controllers
  • There should be two sound options in my experience right click on the second one and click properties
  • Click on power Management
  • Untick the box that says "Allow the computer to turn off this device to save power"

this should make the notification only pop up once, hope this helps nearly killed my computer trying to fix this.

-2

Just this moment I rebooted my Samsung laptop after 'rolling back' the driver for Realtek. No 'high volume' warning received but do not yet know of any performance degradation. Windows 10 64-bit.

-2

Hi I resolve that download newest driver realtek and when windows restart I cancel instalation and now I have no warning here is driver: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=24&PFid=24&Level=4&Conn=3&DownTypeID=3&GetDown=false

Not the answer you're looking for? Browse other questions tagged or ask your own question.