3

The problem

My usually decent 5 Mbps home connection has been extremely slow for the past few days, with all pages I visit taking much longer than usual, some taking more than 30 or 50 seconds to load. (Sometimes the pages will load in 7 - 10s, but the images taking way longer to display).

The setup

I have a single device acting as ADSL modem + router + wireless AP. There are two laptops, two smartphones and a chromecast as wifi clients, and a console and a file server as wired clients.

  • Everything is using DHCP, no client has fixed IP.
  • PPPoE is configured on the modem and all clients are always on, no authentication needed. It's always been like this
  • There's no proxy, firewall, VPN, tunnel or anything like that.

Preliminary diagnostics

The speed reported by speedtest.net is 4.9 Mbps and a 17ms ping:

enter image description here

But, there's a noticeable lag when rendering pages. I inspected the network tab on Firefox and noticed for each request a huge slowness on the "connecting" step:

enter image description here

In the screenshot below, there are 3 KB images taking 50s to load!

enter image description here

What have I done

  • Rebooted the router
  • Positioned the laptop 30cm from the router
  • Switched from WiFi to wired Ethernet
  • Booted into a fresh Live USB Ubuntu install
  • Changed the wifi password and made sure I was the only active client
  • Changed DNS servers from Google's (8.8.8.8) to OpenDNS' 208.67.222.222 and 208.67.220.220
  • Tried SSH tunneling thru a remote server as SOCKS proxy on firefox
  • Tried using a VPN, but the slowness of the connection prevents it from starting.

Nothing seems to mitigate the issue. How can I proceed?

7
  • Have you checked to see that it really is an Internet problem, not one with your local Wi-Fi network? You don't own the airwaves, and you must share them with others. Any new WAP,around you which operates on the same channel that you are using will have a detrimental affect on your throughput.
    – Ron Maupin
    Oct 25, 2015 at 23:43
  • @RonMaupin will try on wired Ethernet and report back. Oct 25, 2015 at 23:44
  • you should check out the number of open TCP sockets. I had an issue where one app was using tons of TCP sockets but very little bandwidth. When I killed that app everything was great. Oct 26, 2015 at 0:01
  • The last thing you could try is to completely bypass your router and directly connect your PC to the modem. If that is still slow, it could be something changed on your computer, or it is out of your hands, and you will need to contact your ISP. It could very well be a problem on the server end.
    – Ron Maupin
    Oct 26, 2015 at 0:01
  • Then it is out of your hands, and you need to contact your ISP. You may have a clause in your ISP agreement where the ISP will throttle your speed if you exceed a certain traffic threshold for your billing cycle, and you will remain throttled until the start of the next billing cycle. If that is the case, you could investigate if you can upgrade your tier (as an extra cost, of course).
    – Ron Maupin
    Oct 26, 2015 at 0:09

3 Answers 3

3

If the wired connection is also slow it's time to contact your broadband/internet provider. The Linux live boot CD eliminates your operating system and if both wired and wifi are slow that eliminates a hardware problem on the PC side. That just leaves your router and the service. If the router belongs to your provider, and things are slow plugged directly into it, they're on the hook to fix it.

If it's your own router, you might try plugging into your provider's hardware directly using the live boot CD. If that's fast the problem is your router.

2

Definitely try using a wired connection first. Disconnect from the wireless network or disable the wireless network adapter, plug in directly and try your test again. If it's still slow, then you know it's a problem with your internet service provider or the modem/router. Either way you can probably get the ISP to help.

If the wired connection is better, then there's obviously something wrong with the wireless. Try using an app like WiFi Analyzer to see if nearby networks are getting in the way. If the airwaves look clear, there may be something wrong with your computer's wireless adapter. You can always buy a different external (USB) WiFi adapter from a store like Best Buy and then return it if that's not the problem.

1
0

The solution was to disable the router's internal DNS server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.