2

I'm using Skype 7.131. I'm using Windows 10, refreshed two days ago, meaning I haven't touched compatibility settings or anything I could've forgotten about. I have a HiDPI display, set to 225% scaling.

Because Skype's font sizing decisions are inscrutable2, I wanted to adjust my font size for the messages at least. I bumped it up to about 16pt, and the fonts showed up gigantic, so I changed it to the smallest size available - 8 pt - and they're still huge.

Is there any way to meaningfully adjust font size in Skype, or is this a known bug in Skype and all I can do is wait?

1. ...point something, see screenshot below.
2. Why are half the UI elements 1-2 pt smaller than the standard systemwide font size?!

Screenshot of Skype message window with overly large fonts.

Screenshot of Skype options dialog, with the IM Appearance tab opened.

Screenshot of Skype "about" dialog.

3

Check at:

C:\Users\{username}\AppData\Roaming\Skype\{Skype account name}\config.xml

and change FontHeight parameter.

  • Indeed, setting it to 16 in the dialog, changed that attribute in the config file to be 40. It seems like they're... multiplying it by the scale factor for some insane reason... Ugh. Anyway: thanks a lot, this works. – millimoose Oct 29 '15 at 23:11
1

Same problem here at 151 DPI - font size can must be a minimum of 8pt in Skype options.

In config, it can go lower - a setting of 12 FontHeight results in a 6pt font.

If it keeps changing, set config.xml to Read Only.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.