5

I started getting this error when I open Cisco AnyConnect,

VPN Service not available

then

the vpn agent service is not responding please restart this application after a minute

Everything was okay. The only thing I suspect is altering the hosts file. I restored it. I tried lot of things, such as flushing the sockets and appending \r\n in the hosts file. It worked for a while and then broke again.

I'm using Windows 7 64-bit and Cisco AnyConnect 3.1.5152.

Link to event details.

  • Are you able to ping the site ? – pun Oct 26 '15 at 19:10
  • Yes, I can ping the site, I see this errors even with a clean installation, without even configuring the site – elarichi.y Oct 26 '15 at 19:14
  • I've added your error log to pastebin so people don't have to connect to an anonymous Google Drive link: pastebin.com/V7ggxM9v – Burgi Oct 10 '16 at 22:03
4

EDIT:

  1. On Windows Press Win+R (windows key and R) to open run dialog.
  2. Type "services.msc" and hit Enter to open Service Manager.
  3. In the Services Manager look for "Cisco AnyConnect Secure Mobility Agent".
  4. Right Click, Open Properties and Set "Startup Type" to "Automatic". Hit "Apply" and then "OK".

I had the same problem. I checked the services.msc for Cisco AnyConnect Service and found it was disabled for some reason. I just changed the service type to automatic and started it which solved the issue. Hope it helps.

  • 1
    This is conceptually quite similar to another answer relating to (re)starting the AnyConnect service, though it does hint at where to find it. Can you expand a little more for those who might not know how to set a service type or start one? – bertieb Feb 18 '17 at 15:41
2

I just restarted the Cisco AnyConnect service and that cleared it up for me.

0

I was facing the same issue, but finally resolved by the below:

  • Restarting the Base Filtering Engine in Services.msc.
  • uninstalling the Application, followed by a reboot.
  • then upgrading to 4.3 version.

Disable ICS – internet connection sharing service

0

If you using widows OS, go to: Control Panel\Network and Internet\Network Connections

and enable "Cisco AnyConnect Secure Mobility Client" virtual adapter.

0

I got the same message:

The VPN service is not available. Exiting.

My solution is to uninstall the Cisco ANyconnect, and delete folder Cisco ANyconnect under Program Data, and restart. Install again with the same version.

Without removing previous folder it will not solve the issue. Try it.

0

I got this error after previously disabling Cisco AnyConnect Secure Mobility Agent in services.msc. For some reason, running Cisco AnyConnect from the taskbar doesn't automatically restart this service. Setting it to both "Automatic" and manually starting it by right clicking the service and selecting "start" fixed the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.