1

I have a following problem on Windows 7 64bit, with OnBoard Ethernet on MSI K9N Neo V2 MotherBoard: I have connected my PC to a router via UTP cable, but it can't connect to local network. I eliminated the following causes:

  1. Router issues - Router is just fine as my other PC connects to the Internet with no problems.
  2. Damaged/Broken cable - I tried both cables I have on my old computer, and they're just fine.
  3. Network Adapters collision - I only have that NIC installed on MotherBoard, no additional network cards
  4. NIC hardware failure - most of the tech forums I searched through trying to fix this problem, have users saying that you can test whether your card is physically OK if you can ping itself(loop-back), and pinging 127.0.0.1 works just fine.
  5. Dust - yes, I even tried blowing(no pun intended)
  6. BIOS - I tried loading optimized defaults, no go. I checked whether OnBoard LAN is enabled, and it indeed is.
  7. Drivers - Tried both Windows update drivers and manufacturer drivers(both old, that came with the motherboard, and latest update for Realtek Ethernet on their website).
  8. Resetting WinSock - netsh winsock reset C:\resetlog.txt, no go. However, I didn't get the log, not sure why.
  9. FlushDNS/RENEW - Doesn't work due to media being disconnected(ie. not connected to any networks)
  10. Re-enabling Local Area Connection/Removing it/ - No go.
  11. Uninstalling device using device manager/look for new hardware/install drivers - No go.

That covers most of what I have tried so far, but no luck. Now, let me show you my IP config:

CMD output

EDIT:

I also tried it on Ubuntu(Live CD). It doesn't report any errors, but it still doesn't connect. Then I stumbled upon THIS, on ubuntu forums, and the problem for this guy was that the drivers that were loaded were made for a different kernel. Then I checked my NIC's ID in linux' lspci, and it says: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411, so I downloaded appropriate drivers for Windows(I couldn't try them on Ubuntu as I was running the Live CD so it wasn't possible for me to remove/add drivers), and it still doesn't work.

Also, WRT NIC blinking yellow/green: I noticed it blinks 4 times rapidly when I start my computer(seems like it starts blinking when computer starts initializing hardware), and no blinking past that point. I expected to see some blinking when NIC tries to find a network(i.e. when OS is loaded and loader circle appears over network icon in system tray), but it doesn't blink.

  • Are there blinking lights on the nic? Also, with some odder issues, I found leaving my PC unplugged overnight. Damn if I know why. – Journeyman Geek Oct 27 '15 at 3:20
  • I tried leaving it unplugged for 30 mins with removed battery, and pressing power button several time(while unplugged) to clear any electricity left out in the loop), didn't help. WRT blinking: yeah, but it doesn't bling rapidly like as if it's looking to connect to a network, as my other computers do, but it blinks twice every once in a while. – Milos Oct 27 '15 at 3:21
  • Have you tried running from an Ubuntu Live DVD to test networking? This could be a driver issue... – Daniel Oct 27 '15 at 3:30
  • Just tried, and it doesn't work. – Milos Oct 27 '15 at 4:37
  • Sounds dead to me – Journeyman Geek Oct 27 '15 at 9:00
1

All you've posted (especially same issues on Ubuntu) points to a dead NIC. RMA the board.

| improve this answer | |
  • Just checked with service, it surely is. – Milos Oct 28 '15 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.