2

System

In my office I am working at a computer with a German version of Windows 7 and a German Office 2010 suite.

The Windows system language has been changed to English. The Office applications have the same language as Windows.

We have German keyboards but I changed the keyboard language to U.S. English. This also works fine.

Standard Shortcuts

These work fine:

  • CTRL+B for bold
  • CTRL+F for find
  • CTRL+Z for back (CTRL+Y on the German real keyboard)
  • CTRL+I for italic word fine.

Shortcuts with the "Shift" key do not work properly

  • Show/Hide has CTRL+( according to the "Customize Keyboard" window. Thus, I should type CTRL+Shift+9 to get CTRL+(.
  • However, I have to type CTRL+Shift+8 which is CTRL+* on the English keyboard but would be CTRL+( on a German keyboard.

Subscript and Superscript

  • Typing CTRL+= does nothing
  • CTRL++ does subscript (but it should do superscript)
  • The correct keys are assigned in Word configuration.

Now I set the hot keys manually.

  • Typing CTRL + = for subscript works fine.
  • Typing CTRL + Shift + = for superscript shows CTRL + * as the assigned hotkey (which is CTRL+Shift+8).

Back in Word: I type CTRL+Shift+8 which does "Show/Hide". I type CTRL+Shift+= which does superscript.

Opening the customize keyboard window again shows the assignment of
CTRL+* for superscript as before.

Summary

Shift + = is printed as + when typed in a MS Word document. But CTRL + Shift + = is not interpreted as CTRL + + but as CTRL + *.

The same states for Shift + 8 which is printed as * but in combination with CTRL recognized as (.

The problem does not arise at our Terminal Server which runs Windows Server 2008 R2 Enterprise.

It might be related to Word 2010 superscript shortcut stopped working.

Question: Why does MS Word behave in this way? How can this issue be solved?


edit:

Interestingly, the shortcuts CTRL + Shift + = and CTRL + = work fine in MS Powerpoint 2010 on the same machine.

I tried the same on fresh installed Windows 7 and the problem is reproducible (German Windows, change System Language, change Keyboard Settings to U.S. English):

  • MS Word: hotkeys CTRL + Shift + = and CTRL + = do not work
  • MS Powerpoint: hotkeys CTRL + Shift + = and CTRL + = do work
  • Did you take into account the difference in US keyboard layout versus the German / European keyboard layout? – Leathe Oct 27 '15 at 11:20
  • On the US keyboard the "="/"+" key is left of backspace. On the German keyboard the "´"/"`" key is left of backspace. If I type that key (left of backspace) I get "=" and if I type it with "Shift" I get "+" as it should be on the US keyboard. Was that your question? The other keys work as well as they should work on an US keyboard. – daniel.neumann Oct 27 '15 at 11:33
  • It's not very clear what your real question is. – DavidPostill Oct 27 '15 at 12:18
  • I added a summary and modified the question. Is it clear now? – daniel.neumann Oct 27 '15 at 12:40
  • 1
    Have you found any solution for this? It completely does not work on my German keyboard. – Mohammed Noureldin Feb 14 '18 at 19:52

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.