0

Problem: When I hit a key to slide the lock screen image up, it takes a second until the password field is in focus. I have to wait a second before I'm able to start typing my password.

I've done a bit of research and have found a way to DISABLE the Windows 8 lock screen, which would technically solve my initial problem. However, I still want to keep the lock screen image.

So I was wondering if there is a way to speed up the animation (preferably instantaneous) when the image slides up to reveal and focus on the password field.

2

Turns out there is a setting to remove the animation, hidden in the Metro Settings.

In the start menu, type "animations", select Turn Windows animations on or off under PC Settings, and switch the slider off for Play animations in Windows.

I'm not sure what else this would affect, but now my lock screen image goes away instantaneously and I can type my password without delay.

Edit: The same setting is also under the classic Control Panel > Ease of Access Center > Make the computer easier to see. At the bottom of the page, check Turn off all unnecessary animations (when possible).

1

There are settings that control the animations you see in Windows. Open "System" and select "Settings..." under the Performance section of the Advanced tab.

I chose the "Adjust for best performance" and it stopped the lock screen from sliding. I don't know exactly which of the checkboxes did it - if you find out, please comment. Nothing specifically says lockscreen, so whichever one it is, you'll probably end up having an effect on some other areas of Windows.

screenshot

  • 1
    Kevin Lau's answer is much cleaner, I'm actually going to upvote his. – LevenTech Oct 28 '15 at 0:14
  • This settings page was the first thing I thought of, but there are several settings which help with readability that I didn't want to mess with. I didn't actually expect it to affect the lock screen though, nice find. – Kevin Lau Oct 28 '15 at 0:28
1

The lock screen animation cannot be disabled on its own, it's consolidated within the setting Animate controls and elements inside windows found underneath Performance Options.

There are a couple of ways to open this specific window:

  1. WIN + R, type in "SystemPropertiesPerformance" and click on OK.
  2. Right Click Start > System > Advanced system settings > Performance.

Finally, remove the check mark from the previously mentioned setting.

Going into the registry doesn't help either, the animation is consolidated like before. Change the key by going to "HKEY_CURRENT_USER\Control Panel\Desktop\UserPreferencesMask", then modify the 5th value (12 = On, 10 = Off).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.