I've just finished 3 day download (with breaks) of Server 2008 R2, and am very eager to install it on my dev machine (my laptop, an HP Pavilion with a 2xTurion 64 cpu). If I mount the ISO and try and run Setup.exe, I get told Setup.exe is not a valid Win32 application. I tried burning the ISO to DVD (as files), but my machine wont't boot from DVD. If I re-insert the DVD, so that autorun comes into play, I get told something like "the setup is not valid for this version of Windows"

Any suggestions as to what I might try, either to diagnose the problem, or to avoid it?


Your problem is that you cannot do an "upgrade" to Server 2008R2, which is what is attempted when you run it from inside Windows.

You need to burn the actual image to the DVD, not the files contained within the .iso. If you just extract the contents of the .iso and burn those, you don't get the boot image of the DVD, which tells the computer that it is bootable. Almost all DVD/CD burning software has the capability of burning an image (the .iso) to a disk. Windown 7 ven has this functionality built in to the OS.


It's possible the download is corrupt, have you verified it?

You may also be trying to install a 64-bit version on 32-bit Windows. In that case, you cannot do the install from within Windows, you need to boot from the DVD.

When burning an ISO file, you must burn it as an image rather than as files, since it is a disc image. ImgBurn can help you with this, simply select write image file to disc:

alt text

When booting from DVD, you'll have to make sure the DVD drive has boot priority. The easiest way is to access the boot options menu. The key may vary depending on your system, mine is F12.


I ran into the same types of problems you are when I installed Windows Server 2008 R2 x64. If I ran the setup.exe from within Windows 7 x64 I got the the setup is not valid for this version of Windows message. I was able to boot the DVD, but the setup always told me it couldn't find drivers for my DVD drive.

I ended up re-downloading the ISO and it worked perfectly. I suggest you verify your ISO image and if possible re-download it. If possible try not to have any breaks in the download, I think I had breaks in my first download as well. Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.