I have some programs running on start-up like Everything. UAC prompts every time the Windows starts. How can I set a program to make sure that no intervening prompt would appear during start-up?


8 Answers 8


Task scheduler is an ok solution for something that runs on startup. But the most flexible way to do this is to use the Microsoft Application Compatibility Toolkit. It enables you to directly disable UAC for any application you decide to trust. The compatibility fix you need to select is RunAsInvoker.

Edit 19.5.2023: Seems like the Microsoft Application Compatibility Toolkit is not supported on Windows 11. However you can enable the same RunAsInvoker setting using NirSoft AppCompatibilityView.

  • This seems to be the best answer. I'm worried I'll have to play with the match settings so it doesn't ask after the next update, but it's a start...
    – Rob I
    Commented Mar 2, 2013 at 17:43
  • 4
    Explanation article:How to start and bypass UAC for your trusted applications
    – IvanH
    Commented Nov 8, 2013 at 12:25
  • 1
    This video explains it well.
    – zar
    Commented May 30, 2018 at 15:01

To disable UAC prompts for one application only you have to use the Microsoft Application Compatibility Toolkit:


You have to run, as administrator, the correct "Compatibility Administrator" program. There are two of them, one for 32bit applications and one for 64bit applications.

  • On the left hand tree menu, on the bottom is "Custom Databases", and under it "New Database(1) [Untitled_1]"
  • Right click on the "New Database(1) [Untitled_1]"; select Create New, and Application Fix.
  • Enter the name and other details for the application you want to alter behavior on and then browse to it and select it.
  • Click Next until you are in the Compatibility Fixes screen.
  • On the Compatibility Fixes screen, find the item RunAsInvoker, and check it.
  • Click Next and then Finish.
  • Select File and Save As.
  • Save the file as [filename].SDB in a directory you can type easily on the command line.
  • Open a Command Prompt as administrator.
  • Run the command: sdbinst [drive]:\[path]\[filename].sdb & pause (For example I was fixing the UAC for Clover and the command I typed was:

    sdbinst "C:\Program Files (x86)\Clover\Clover.SDB" & pause

  • You should get a new window that says:

Installation of [name] complete.

Press any key to continue . . .

And that worked for me... Good Luck! - Sy

  • 2
    Followed the steps here and now Everything won't prompt for UAC, then won't run, but will run if manually UAC'ed via right-click context.
    – ian5v
    Commented Oct 14, 2013 at 7:12
  • Doesn't work here too
    – majkinetor
    Commented May 14, 2015 at 6:56
  • Also doesn't work for me but the link given in the second comment of the most upvoted answer did the trick.
    – MagTun
    Commented Aug 24, 2015 at 9:14
  • Note that this doesn't work for Visual Studio 2017 on Windows 10 (not what the question asked about but FYI if you're looking for a solution for this specific scenario). For Windows 10, you need to download something different called Windows Assessment and Deployment Kit (ADK) for Windows 10 available under "Related Resources" in the above link. And then only check to install Application Compatibility Tools. From there steps are similar. It just doesn't work for the Windows 10/Visual Studio 2017 combo (not sure about other Windows 10 apps).
    – EF0
    Commented Jun 2, 2017 at 16:59

Task scheduler is your friend (Basic Task - Start Program at Log On - check Highest privileges).

Don't forget to remove (or move) your current startup icon or registry entry afterwards.


I was getting UAC prompts for CPU-Z and Malwarebytes, even though I had configured them to run as administrator, and in own memory space etc.

I had to go to administrative tools, local security policy, security options, user account control: behaviour of the the elevation prompt for administrators in admin approval mode. In that you get a few options for behaviour, selecting the elevate without prompting got rid of annoying warnings and system hasn't been compromised to date.

I'm running Windows 7 Enterprise 64 bit.

  • 1
    local security policy is not available in Windows 7 Home version
    – MagTun
    Commented Aug 23, 2015 at 8:36

A third party program you might want to take a look at is called UAC Trust Shortcut 1.0

Basically you just download the program and enter in the .exe location and a name for the file and the icon will be placed on your desktop. The service will run in the background to allow easy access to any of your account restricted links.

The download can be found here: http://www.itknowledge24.com/

enter image description here


I had that problem with one app. At startup popup a window to permit it to run, I used many answers but the solution was to click on Unblock in Properties.


Was looking for a method of opening a third party security program as Administrator on system startup, (several of its features require it be started in Admin mode for the features to function as configured).

Here's the process worked through to arrive at the desired result:

  • Changed the application launch properties to 'Run as Administrator': FAIL #1
  • Created a desktop shortcut with Admin privileges and added it to the 'Startup' group. While the application opened, it did not open in Administrator mode: FAIL #2
  • User Task Scheduler to open it on system start (using the method provided by the winaero blog) but as the application prompted a UAC question, it wouldn't load: FAIL #3
  • Lost an hour of life downloading, installing and working through 'Microsoft Application Compatibility Toolkit': FAIL #4
  • Won't class this as a failure, but looked at UAC Trust, found it didn't address the question posed here.

At this point, somewhat invested in the, '15 minute job' now morphed into, 'Day 2' status. Felt the needed components were at hand but was blind to them.

Reassessed the parameters of the problem and employing the Kalashnikov engineering rule #1 (whether the mechanism is clean or dirty, it should work) reconsidered each known element, not looking for what was missing, but for what parameters could be altered without shifting the desired goal, the 'automatic start of a 3rd party app in Admin mode'.

Returned to the Task Scheduler, reworking task switching the Trigger from on system startup to on log on and on the next login, the application started, in Admin mode. Huzzah! Success!

Kudos to winaero for providing the comprehensive visual and written documentation. If I weren't technically oriented, I would have tried their Tweaker. It's what I'll use on the Windows 10 systems.


If you right click on the application executable, click properties then on the compatibility tab select "Run as Administrator" then click apply, you should no longer get the warning box.

  • 2
    Nope, it didn't work. Commented Jan 22, 2010 at 20:23
  • This is the correct answer, I'm surprised it was -1, it's also explained in details here: superuser.com/a/33377/31927 Commented Oct 26, 2012 at 18:13
  • 3
    @MarcoDemaio, it was down-voted because it is not correct. That setting does not suppress the UAC prompt which is what the question was asking.
    – Synetech
    Commented Nov 27, 2013 at 2:19
  • 1
    Depends whether you go by the title of the question the main body of the text. It solves: "How can I set a program to make sure that no intervening prompt would appear during start-up?" Commented Jun 3, 2014 at 10:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .