3

There's a very similar question here: Disable scrolling to next slide in Powerpoint Edit Mode, but unfortunately the two answers don't really answer what the title of the question appears to ask.

In PowerPoint 2013 when you're in the edit mode the scroll wheel switches between slides. Unfortunately for me my mouse's scroll wheel is very temperamental and a slight touch of it is enough to trigger it. This isn't an issue when viewing web pages or editing text documents as the scroll usually isn't enough to do anything, but in PowerPoint it appears that even the slightest of scroll will change from one slide to the next.

I want to either disable the scroll wheel completely in PowerPoint or set it to instead scroll on the current slide view rather than move onto the next slide. Is this at all possible?

  • I think you would better of buying a new mouse if your current one is so temperamental. – DavidPostill Oct 28 '15 at 9:45
  • @DavidPostill definitely. Unfortunately that requires money. I've been using this mouse in its current state for over a year now and I've not really had any big problems with it until now. It's really annoying to be half way through editing a slide to have it move onto the next one without you wanting it to though, so I figured this would be something they'd let you disable. – James Donnelly Oct 28 '15 at 9:47
  • Have you tried adjusting how much the scroll wheel moves in Control Panel? Maybe that will reduce its sensitivity? – Andi Mohr Oct 28 '15 at 9:58
  • 1
    Another thing you might try is using AutoHotKey - have a read of this, it might help you: autohotkey.com/board/topic/… – Andi Mohr Oct 28 '15 at 10:01
0

This AutoHotKey script does exactly what you want – tested:

#IfWinActive ahk_class PPTFrameClass ahk_exe POWERPNT.EXE
WheelUp::return
WheelDown::return
#IfWinActive

Features:

  • mouse wheel is disabled only when main window is active
    • if you occasionally need to use the wheel, hold Shift, then it works
  • mouse wheel works without restrictions (as normally) if presentation window is active

Happy presenting!


From a comment below:

Also make sure to set the #MaxHotkeysPerInterval 200 in the AHK script.

| improve this answer | |
  • But he does want to disable it in edit mode not in present mode. – Phil Roggenbuck Jan 24 '19 at 9:23
  • @PhilRoggenbuck – thanks for heads-up. Answer corrected. – miroxlav Jan 24 '19 at 9:33
  • now its kind of working, it just disabled all scrolling. Which is a partial solution to what he wrote here I want to either disable the scroll wheel completely in PowerPoint or set it to instead scroll on the current slide view rather than move onto the next slide. Is this at all possible? – Phil Roggenbuck Jan 24 '19 at 9:36
  • @PhilRoggenbuck - not easily using the AHK. After high effort, perhaps the main window can be reverse engineered and then scroll wheel will send the message only to that panel. Perhaps someone with advanced experience can achieve it in AHK. – miroxlav Jan 24 '19 at 9:38
  • Yeah I know :) But good idea to do that with AHK – Phil Roggenbuck Jan 24 '19 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.