0

System information

  • Operating System: Windows 7 Professional with Service Pack 1 64-bit
  • Google Chrome version: 46.0.2490.80 m (up to date)
  • Default printer: Toshiba eStudio 2330C
  • Default printer driver: TOSHIBA e-STUDIO2330C XPS x64
  • Default printer driver version: 0.3.7607.17514 (according to file version of the driver file C:\Windows\System32\spool\drivers\x64\3\mxdwdrv.dll)
  • Default printer driver provider: Windows (according to the driver file C:\Windows\System32\spool\drivers\x64\3\mxdwdrv.dll)

 

Issue

In Google Chrome when printing (be it a webpage or PDF) and using the "Print using system dialogue" option, Google Chrome acts strangely. Here are some details:

  • The "Print" window has no Taskbar item of its own and is always at the front when Google Chrome is open (I presume this is because it's running as part of Google Chrome)
  • The "Print" window's close, "Preferences", "Print", "Cancel", and "Apply" buttons do not work - they are interactive but do not do anything when selected.
  • The "Print" window's printer list scrolling, "Find Printer..." button, and "Page Range" radio buttons do work.
  • Printing the same document normally results in a completely white print preview.
  • There are no relevant Application or System events logged.
  • Closing Google Chrome keeps 3 chrome.exe * 32 processes open generally frozen at ~30MB, ~32MB, and ~120MB. Google Chrome will not open again unless these processes are killed.

 

Steps to reproduce problem

Unknown. Problem is intermittent and only applies to one PC but is very frequent.

 

Fixes

  • Does work: Closing Google Chrome, killing remaining 3 chrome.exe * 32 processes via taskkill /f /im chrome.exe, and opening Google Chrome.
  • Does not work: Ending the Print: <document name> or Mimehandler: <document name> processes via Google Chrome's Task Manager.
  • Does not work: Restarting the spooler service.
  • Does not apply: Installing the XPS Essentials Pack as it's not compatible with Windows 7.
  • Does not apply: Installing .NET Framework 3.5 as it was already installed as part of Windows 7.
  • Does not apply: Disabling the Chrome PDF Viewer plugin as the issue happens when printing webpages.
  • Have not tried: Changing the default printer as that needs to be the default printer.
  • Have not tried: Changing the default printer driver as it works fine for other applications.
0

Completely reinstalling Google Chrome seems to have resolved the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.