I am running Windows 7 Ultimate - 32 bit. Out of nowhere, this morning when I started my PC, every single folder that I double-clicked opened a new window. That's quite annoying. Even though the options in the Folder Settings is set to "Open each folder in same window". Only when I right click and click "Open", the folder opens in the same window.

I read an article on that exact problem here

I tried regsvr32 "%SystemRoot%\System32\actxprxy.dll" which works ok and regsvr32 "%ProgramFiles%\Internet Explorer\ieproxy.dll" which gives me the following error: the error

Exact Translation:

Failed to load module " C:\Program Files\Internet Explorer\ieproxy.dll".

Make sure the binary data stored in the specified path or debug it to check for the presence of any problems with bilateral DLL files or affiliates.

Could not access the specified module.

Anyways, I restarted but still the same. All folders open in new windows.

Also, Iv'e read that this problem is connected with Internet Explorer, I am currently looking into that.

  • 1
    Please check addendum to my answer.
    – JosefZ
    Commented Oct 30, 2015 at 0:48

1 Answer 1


Check default value of the HKEY_CLASSES_ROOT\Folder\shell registry key. File explorer would behave as described in case opennewwindow:

==> reg query "HKEY_CLASSES_ROOT\Folder\shell" /ve

    (Default)    REG_SZ    opennewwindow

The value should be either empty:

==> reg query "HKEY_CLASSES_ROOT\Folder\shell" /ve

    (Default)    REG_SZ

or undefined:

==> reg query "HKEY_CLASSES_ROOT\Folder\shell" /ve

    (Default)    REG_SZ    (value not set) 

Addendum. Another cause under HKCR\Folder\shell\open key: if LaunchExplorerFlags value exists and its data is not equal to 0x0 then its non-zero value overrides the Open each folder in same window setting, for instance (poorly documented, see also its another use in Disable Open Folder In New Window, In Windows 8 Explorer):

  • 0x1 is equivalent to HKCR\Folder\shell\opennewwindow;
  • 0x3 is equivalent to HKCR\Folder\shell\opennewprocess;
  • 0x18 could comport with HKCR\Folder\shell\explore (however not tested under open key).

The LaunchExplorerFlags value should either be missing as follows

==> reg query "HKCR\Folder\shell\open" /v LaunchExplorerFlags

ERROR: The system was unable to find the specified registry key or value

or show

==> reg query "HKCR\Folder\shell\open" /v LaunchExplorerFlags

    LaunchExplorerFlags    REG_DWORD    0x0


==> reg query "HKCR\Folder\shell\open" /s

    MultiSelectModel    REG_SZ    Document
    LaunchExplorerFlags    REG_DWORD    0x0

    (Default)    REG_EXPAND_SZ    %SystemRoot%\Explorer.exe
    DelegateExecute    REG_SZ    {11dbb47c-a525-400b-9e80-a54615a090c0}
  • Weird thing is , it is undefined when i checked now
    – Kai22315
    Commented Oct 29, 2015 at 5:40
  • Thanks sir , but the issue was related to faulty internet explorer , thanks anyway
    – Kai22315
    Commented Oct 30, 2015 at 7:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .