3

In an attempt to repair an old Dell Inspiron laptop that was previously repaired (sent to a repairman and clean installed), I am stuck at this issue. Since that last repair, the laptop still has issues and the Windows Updates have all been failing.

When it attempts to apply the changes, Windows Update will fail into a "Failed to configure ... reverting changes" restart loop. It also appears that all of the ones that fail are security updates.

When trying to run chkdsk /f /r, it will tell me:

The type of the file system is NTFS.

Cannot lock current drive.

Chkdsk cannot run because the volume is in use by another process.

When trying to do sfc /scannow it will tell me:

There is a system repair pending which requires reboot to complete.

Restart Windows and run sfc again.

I am only assuming I can't use those commands because Windows Update is in the way? I've scanned with Malwarebytes (VIPRE is also installed) so the issue should not be a virus or malware.

Using the WindowsUpdateDiagnostic will fix a couple issues but fails at fixing "Service Registration is missing or corrupt."

I am lost on where to go as nothing appears to be working.

System overview

  • Dell Inspiron (2009)
  • Windows 7 Home Premium SP1 64-bit
  • 4GB RAM
  • Just noticed that when applying updates on restart it will exit and go to the desktop on update 2 of ... (_0000000000000000.cdf-ms) – Matthew Wright Oct 29 '15 at 3:14
  • share the logs from the folder C:\Windows\logs\CBS. Maybe I can see what causes the setup failures – magicandre1981 Oct 29 '15 at 5:41
8

Windows Failure - Recovery Console (Steps and Commands)

Leave a comment below with the error, or anything else you think may be helpful to others, which these steps helped you resolve.

(Links at bottom for step-by-step instruction still for getting to Recovery Console and Safe Mode)

Run the below #1 command (steps) first to find out which drive letter is assigned to the Windows OS partition from the Recovery Console as it may not be the standard "C" drive as it is otherwise.

  1. From the Recovery Console type in bcdedit| find "osdevice" press Enter and then look at the command output result.

Where you see osdevice partition=D: (output result of the command per #1) whatever drive letter is after parition= is the drive letter you'll use in place of C:\ in the below command so if it's ~D= then the below command will use ~image:D:\ /cle~ in that part of the command.

Warning: Ensure spaces are in the command and the forward and back slashes are just as typed.

  1. From the Recovery Console type in dism /image:C:\ /cleanup-image /revertpendingactions, and press Enter

    • If you get the error. . .
      • The scratch directory size might be insufficient to perform this operation. This can cause unexpected behavior. then. . .
      • type in (assuming OS is on "D" drive here) MD D:\Scratch press Enter then type in DISM /Image:D:\ /ScratchDir:D:\Scratch /Cleanup-Image /RevertPendingActions press Enter to rerun the command.)

If you still have trouble getting #2 to run from the Recovery Console, then try running the below command when logged onto Windows normally from the command prompt (run as administrator). If you're able to get #2 to run without error, then just skip the #3 step entirely.

  1. Type in DISM /Online /Cleanup-Image /RevertPendingActions from the command line run as administrator, and then press Enter.

If you cannot get #2 or #3 to work above, then you may need to boot to a Linux OS or perhaps you can do from Recovery Console and rename the below file on the "C" drive location (or whatever drive letter Windows is on per #1 above still) which is the file that keeps records of where the OS is on pending Windows Updates, etc.

Once this file is renamed, then a new file will be created on the next Windows Update attempt but if you have to run this option to fix the issue, it may be best to do #5 before applying any new Windows Updates.

  1. This is the file that you'll rename ->C:\Windows\winsxs\pending.xml

    Ensure you replace C:\Windows\~ with the drive letter determined in #1 above here too

    • From the Recovery Console type in CD /D "C:\Windows\winsxs" press Enter

    • Type in REN "pending.xml" "bak_pending.xml.bak" press Enter, reboot machine and complete #5 below

  2. Once that completes, boot to Safe Mode and then run the below command (optional):

    • Type in sfc /scannow from the command line run as administrator, and press Enter.

NONE OF THIS IS WORKING!!!

A few last resort items to try in order and from the Recovery Console. . .

Anywhere a drive letter is anywhere on any of the commands, ensure the drive letter is what's determined per step #1 above.

  1. CHKDSK D: /F /R < Let this complete regardless of how long it takes to complete; kick it off, and just check in on it periodically.

  2. SFC /SCANNOW /OFFBOOTDIR=D:\ /OFFWINDIR=D:\Windows


Important Note Installing Service Pack 1

Once you get this fixed, please download the Windows 7 Service Pack 1 manually (below download link), install it, and then reboot.

Be sure to not apply any Windows Updates via the Windows Update process until this is complete. Once Service Pack 1 is downloaded and installed, then move forward with the Windows Updates.

Download


Further Resources

  • That worked perfectly. I've went on to step 5 and encountered an error at 97% "Windows Resource Protection could not perform the requested operation." Pastebin to the last few lines where the error occured in CBS.log – Matthew Wright Oct 29 '15 at 20:19
  • I think it is fixed! All the failed updates are installed now, hope nothing else is still broken. Thanks PJ! – Matthew Wright Oct 31 '15 at 1:01
  • To add what I've done since and maybe to add to the solution. Windows Update installed updates just fine but would not find updates (Errors 80080005, 8024####, and the message "Find out about more free software from (null). Click here for details"). I read to update Windows Defender/MSE (definition update) and it solved the problem - at this point the computer is completely fixed, works like new, and eligible to upgrade to Windows 10. – Matthew Wright Nov 1 '15 at 20:27
2

From the log I can see that you get a ERROR_RM_NOT_ACTIVE error. Open Explorer, delete all files from C:\Windows\System32\config\TxR (make sure hidden files are shown in Explorer), now open a cmd.exe as Admin and run this command:

fsutil resource setautoreset true C:\

Now reboot Windows and after the reboot, try to install the Updates again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.