12

Windows 10 has a dialog that asks

How do you want to open this file?

Here's a screenshot I found on the web:

enter image description here

I think it does this for every file type once.

Since I have a lot of types that basically open Sublime (js/java/cs/h/c/cpp/txt/md/...) this get's annoying quick.

Is there a way to get Windows to "keep using this app" without displaying the dialog for all file types that were known previously on Windows 8?

To be clear:

  • The file associations for all types has already been set (in Windows 8)
  • After upgrading Windows 10 asks again once for every file type showing a dialog with "continue using this app"
  • Since it already knows what app I want to use (hence the "continue using this app" part) how can I stop Windows from asking again?
11
  • Run / gpedit.msc (edit group policy)
  • locate and expand Computer Configuration / Administrative Templates / Windows Components now click on File Explorer
  • on the right panel, double click on "Do not show the 'new application installed' notification" and set it to "Enabled"

This policy removes the end-user notification for new application associations. These associations are based on file types (e.g. *.txt) or protocols (e.g. http:)

If this group policy is enabled, no notifications will be shown. If the group policy is not configured or disabled, notifications will be shown to the end user if a new application has been installed that can handle the file type or protocol association that was invoked.

  • Thanks, I enabled it. Unfortunately I got the same dialog a few minutes later :( – laktak Jan 28 '16 at 13:13
  • this must be a bug, it shouldn't appear. I saw others with the same issue, tho I don't have such problem. I'm guessing your best bet is Microsoft support. sorry It didn't help. hope you find a solution soon. – Maher Fattouh Jan 28 '16 at 13:21
  • Worked for me, now opens the HTML files as supposed and not popping up anymore. – ekussberg Jul 5 '17 at 9:23
3

I never found a solution - maybe it's even intended by MS to push their own apps.

The following workaround however solves it pretty well without interrupting my workflow.

Install AutoHotkey and add this to the top of your script:

; auto close annoying windows
Loop {
  Sleep 500
  if (WinActive("ahk_class Shell_Flyout")) {
    WinGetPos , , , cw, ch
    ; if (cw=710) {
      ; How do you want to open this file? / Keep using this app
      Send {Enter}
    ; }
  }
}

You may need to enable the size check if Shell_Flyout is used for anything else.

0

Some programs neglect to put the path to their executable in quotes when they add themselves to the list of startup apps. The way I fixed this was by using CCleaner to open their registry entries and manually adding quotes to all the paths. Credit

0

Getting "How do you want to open this file?" for .exe files can be due to the executable program trying to open some other file (.html, .pdf, .chm, ...) prior to showing any window or interface, making it seem like the problem is with .exe association

-1

You can set either - default programs for known extensions or services, or specify file extensions and then proper programs for them. While setting "Default program" Windows will automatically open files of extensions already defined and linked to that program. The other option lets you manually override this settings. i.e. its useful when you want to open jpg in one app, and, lets say gifs in other.

Try Control Panel -> Programs -> Defult Programs

Either "Set your default programs" or "Associate a file type or protocol with a program".

Other than that, after "some" time Windows will almost completly stop asking about programs you want to use. Except when you install new program that can handle known protocols (like images, web content).

  • This doesn't really help me with my question. The files types are already associated yet Windows still asks about them. – laktak Oct 29 '15 at 12:15
  • @laktak That's what the "Always use this App to open ..." checkbox is for. – DavidPostill Oct 29 '15 at 13:17
  • @DavidPostill I think you misunderstood my question. I don't want to click on "Always..." I don't even want to see this dialog. The file associations are already set. – laktak Oct 29 '15 at 13:20
  • @laktak You have to check that box the first time. Then you wont see the dialog again for that particular extension. – DavidPostill Oct 29 '15 at 13:21
  • @DavidPostill Like I said, the association has already been set. Is my question unclear? Is this a bug in Windows that only I get? Have you never seen the "Keep using this app" line? – laktak Oct 29 '15 at 13:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.