8

This is an irksome issue that has been bothering me for years now, and I finally figured; I'm probably not the only one.

Imagine this: A dualscreen set-up, two chrome screens open. One on the first screen with a youtube/netflix/social media/etc, the other on the second screen for working.

I'm a webdeveloper so I cmd-tab a lot back and forth to my coding app. Each time I do so, when I get back to Chrome, the 'first' screen is activated, while I was working in the second. When I switch back to chrome it's a force of habit to refresh immediately, causing me to refresh the wrong screen each damn time.

This might sound like a non-issue, but I hope you can understand it's insanely infuriating. Why isn't Chrome just remembering the last active instance as the main window to activate when switching back to it?

Angry sidenote: Google is all about usability and having the experience central. Thing is, I don't really notice it at all in their apps like Maps on mobile, things like this in Chrome etc.

  • 1
    it would also be infuriating if you were listening online using something like Pandora, listening to a good song, it refreshes giving a break in the music, then plays a son you hated since you were a child. perfect, semi exaggerated example – DanHolli Jan 13 '17 at 7:10
  • Sounds familiar, though it seems we're the only two people with such issues ;) – Alex Timmer Jan 13 '17 at 10:14
  • I was giving a theoretical situation, I haven't actually had this problem – DanHolli Jan 13 '17 at 17:43
  • I have up-voted it though, so someone that has had this can help you, eventually when I get more rep, I put a bounty on – DanHolli Jan 13 '17 at 17:45
  • I don't think this is only with Chrome. I am experiencing this with Terminal, on High Sierra. – Elias Zamaria Apr 24 '18 at 23:14
3

I get this problem occasionally too.

I clicked the full-screen (green, right-most) button on a Chrome window in the screen which I wanted to activate first, then toggled it off. That seemed to restore the behavior I wanted.

  • 1
    Just had this happen again recently. Toggling full-screen didn't help, but it seems that unplugging my display from my laptop and plugging it in again did. It's possible that this happens when the menu bar is switched to another screen in System Preferences > Displays > Arrangement. – Vic Sep 7 '17 at 1:03
  • I had another problem where, if i had a chrome window on both monitors, new chrome tabs would open on the wrong one. However, this fixed it – feupeu May 2 '18 at 7:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.