7

I have a problem with a SSD (Crucial BX100) bought last week and Windows 10 install.

When I try to install Windows 10, the installation software don't recognize my SSD, I have a same windows as this one :

enter image description here

I can see the SSD from the BIOS without any trouble.

I also tried two different things : Without changing anything in the configuration of the computer I tried to install a Windows 8.1 instead of a Windows 10, I didn't had any trouble, the install software saw my SSD and I could succesfully install Windows 8.1, so my SSD is correctly plugged to the motherboard and its BIOS configuration is ok.

I tried also to put the SSD on another computer and install Windows 10 on it, it worked without any issue, so my bootable Windows 10 key is ok too.

So, what could prevents me from installing Windows 10 especially on this computer particularly ?

The motherboard is an ASROCK AliveSATA2-GLAN if it can be useful.

EDIT : I tried what as suggested by Keltari and joro, I downloaded drivers from the link of Keltari and also from the motherboard website and tried to load them during Windows installation, and it didn't worked, only one of these drivers was recognized by Windows installer as a compatible driver but id didn't worked.

In his comment, qasdfdsaq spoke about the different SATA connectors of the motherboard. I have 4 SATA connector on my motherboard (2 * JMB363 and 2 * VT8237A) .I was previously using the JMB363 SATA controller (a SATA 2 controller), I tried to use the other one (a SATA 1 controller) and it worked, I succeed to install Windows 10. But I have now two problems :

  • I tried to install the JMB363 driver (from Windows 10, not from Windows installer), and it doesn't work, so I can't use the JMB363 SATA controller again, so my SSD works on a SATA 1 controller...

  • The network driver is missing and I can't install the driver from the motherboard website (the driver's installer software say my material isn't compatible).

  • If you were able to install Windows 8.1 why don't you just install that then upgrade that installation to Windows 10. The, outcome is identical to a clean installation. I don't actually suspect a driver problem in this case, I suspect you attempted to install Windows 10 with Legacy mode enable/disabled and you attempted to install Windows 8.1 in the opposite state. – Ramhound Oct 30 '15 at 11:48
  • 2
    Is your SSD connected to the chipset SATA controller (VT8237A) or the add-on SATA controller (JMB363)? Drivers for the chipset controller are definitely included in Windows 10, though not sure about the setup/PXE. – qasdfdsaq Oct 30 '15 at 12:46
  • Ramhound : I tried 2 times to install Windows 8.1 and then upgrade but the upgrade failed with a BSOD : C1900101-20017 ("The installation failed in the SAFE_OS phase with an error during BOOT operation"). – Alain Oct 30 '15 at 14:53
  • Your hardware is extremely dated. If the network device does not work without the driver you might simply be out of luck. – Ramhound Oct 30 '15 at 15:13
  • I agree that my hardware is dated, but what I really found suprising is the fact that I didn't had any trouble with Windows 8.1. I didn't installed any network driver or SATA driver and everything was working without any problem on Windows 8.1. – Alain Oct 30 '15 at 15:43
4

Windows 10 does not have the driver for the SATA controller. You can download the driver here. Unzip that to a USB stick and when you click "Load Driver" select the appropriate driver and you should be good to go.

  • 1
    To anyone looking for SATA drivers from the manufacturer page, but not sure which one it is: Try the Intel Rapid Storage Technology driver, if present. - It worked for me. – sudoqux Apr 20 '16 at 8:07
  • 1
    At this moment, the link seems to be downloadcenter.intel.com/download/29094/… – Kara Marfia Oct 16 '19 at 14:11
0

You need drivers for the SATA controller, not for SSD. Check AsRock site for them.

0

This worked for me

  1. Download the Windows 10 installation files.
  2. Create a Windows 10 bootable media.
  3. Boot your computer with the bootable media
  4. Click the Repair your computer
  5. Click Troubleshoot. Then click Advanced Options. Then click Command Prompt
  6. Type the following commands to fix the mbr

    a. Bootrec /fixMbr

    b. Bootrec /fixBoot

    c. Bootrec /ScanOS

    d. Bootrec /RebuildBcd

More here - http://pureinfotech.com/repair-master-boot-record-mbr-windows-10/

0

I had similar problem with Crucial BX330 on ASUS A88XM-Plus this week.

I have a multi boot win10/ubuntu system and when i installed SSD as secondary drive, then win10 and BIOS (!) could not recognize the new SSD but ubuntu could. After Bios upgrade, SATA drivers for win10 nothing changed. When i checked ubuntu log i saw that SATA link 6.0 Gbps failed for this drive and finally SSD connected with 3.0 Gbps link. So I changed BIOS SATA configuration to 3.0 Gbps and after that win10 can see the disk (bios also).

Try to slow down the SATA speed or replace components

0

I tried many of the things listed here on the old HP Pavilion P6000 with AMD chipset I was trying to get going. In the end, it was as simple as going into the BIOS and switching the SATA mode from RAID to AHCI.

-1

What works for me was to format ssd into fat32 instead of NTFS. I used Gparted iso to format it in fat32 and then finnaly win10 instaler was able to see my new ssd :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.