My Samsung M3 Portable 1TB is no longer detected in any new ports. Error:

Windows has stopped this device because it has reported problems. (Code 43) A request for the USB device descriptor failed

It used to be detected everywhere including TV. But now suddenly stopped detecting on TV or new PCs or previously unconnected ports in my PC. It seems for old ports, the drivers are already installed, but for new ports, the drivers are not installed and it fails to install.

I have tried uninstalling and reinstalling too in the unconnected ports. But still not working.

Seems to be a hardware issue, but can it be fixed?

The only good thing is it is able to connect to those old ports. But what if, for some reason, the configuration is lost.

Please let me know how to fix this.

1 Answer 1


my best advice for problems with external harddrive is to check for power issues and trying different cables (which is almost the same thing).

I have a number of drives which only work on some ports using specific cables. So a thicker cable usually helps and a USB port providing enough power is essential. They used to give us those cables with an additional USB plug to be able to draw more power for the drive.

Such an additional USB plug can be plugged into another USB socket to improve the provided current which solves the problem in some cases. This works well when the used USB socket is connected to the same power supply, but it might NOT work when a different power supplies is used due to different electric potentials.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .