6

I have a fresh install of the KDE spin of fedora 22. Quite simple install instructions are given here to install steam:

However I get a bunch of conflicts as steam.i686 depends on other .i686 libraries and being a 64 bit install I have x86_64. The conflicts are (of the form file <something> from install of <i686> conflicts with file from package <x86_64>):

elfutils-libelf-0.163-4.fc22.i686
fontconfig-2.11.94-4.fc22.i686
freetype-2.5.5-2.fc22.i686
gdk-pixbuf2-2.31.6-1.fc22.i686
gnutls-3.3.18-1.fc22.i686
krb5-libs-1.13.2-8.fc22.i686
libidn-1.32-1.fc22.i686
libstdc++-5.1.1-4.fc22.i686
p11-kit-0.23.1-2.fc22.i686
pam-1.1.8-19.fc22.i686
pango-1.36.8-6.fc22.i686

I'm quite certain I don't want to replace my system with the 32 bit versions, but I definitely had steam installed fine on my last system. Does anyone know how steam should really be installed, or maybe how I could get these packages installed just for steam?

(I have installed nvidia drivers and their 32 bit version just fine, it's just the 32 bit libraries stopping me from actually installing steam)


UPDATE: full output

> sudo dnf install steam
================================================================================
 Package             Arch    Version                   Repository          Size
================================================================================
Installing:
 alsa-lib            i686    1.0.29-1.fc22             fedora             392 k
 atk                 i686    2.16.0-1.fc22             fedora             259 k
 audit-libs          i686    2.4.4-1.fc22              updates             96 k
 avahi-libs          i686    0.6.31-43.fc22            updates             61 k
 bzip2-libs          i686    1.0.6-14.fc22             fedora              45 k
 cairo               i686    1.14.2-1.fc22             fedora             756 k
 cracklib            i686    2.9.1-5.fc22              fedora              84 k
 cups-libs           i686    1:2.0.3-1.fc22            updates            392 k
 cyrus-sasl-lib      i686    2.1.26-23.fc22            updates            160 k
 dbus-libs           i686    1:1.8.20-1.fc22           updates            171 k
 elfutils-libelf     i686    0.163-4.fc22              updates            212 k
 elfutils-libs       i686    0.163-4.fc22              updates            295 k
 expat               i686    2.1.0-10.fc22             fedora              90 k
 fontconfig          i686    2.11.94-4.fc22            updates            245 k
 freetype            i686    2.5.5-2.fc22              updates            413 k
 gdk-pixbuf2         i686    2.31.6-1.fc22             updates            569 k
 glib2               i686    2.44.1-2.fc22             updates            2.2 M
 glibc               i686    2.21-8.fc22               updates            4.2 M
 gmp                 i686    1:6.0.0-9.fc22            fedora             423 k
 gnutls              i686    3.3.18-1.fc22             updates            617 k
 graphite2           i686    1.2.4-3.fc22              fedora              92 k
 gtk2                i686    2.24.28-1.fc22            fedora             3.4 M
 harfbuzz            i686    0.9.40-1.fc22             fedora             172 k
 jasper-libs         i686    1.900.1-30.fc22           fedora             149 k
 jbigkit-libs        i686    2.1-3.fc22                fedora              51 k
 keyutils-libs       i686    1.5.9-4.fc22              fedora              45 k
 krb5-libs           i686    1.13.2-8.fc22             updates            853 k
 libX11              i686    1.6.3-1.fc22              fedora             617 k
 libXScrnSaver       i686    1.2.2-8.fc22              fedora              28 k
 libXau              i686    1.0.8-4.fc22              fedora              33 k
 libXcomposite       i686    0.4.4-6.fc22              fedora              27 k
 libXcursor          i686    1.1.14-4.fc22             fedora              34 k
 libXdamage          i686    1.1.4-6.fc22              fedora              25 k
 libXext             i686    1.3.3-2.fc22              fedora              42 k
 libXfixes           i686    5.0.1-4.fc22              fedora              22 k
 libXft              i686    2.3.2-2.fc22              fedora              62 k
 libXi               i686    1.7.4-2.fc22              fedora              45 k
 libXinerama         i686    1.1.3-4.fc22              fedora              18 k
 libXrandr           i686    1.4.2-2.fc22              fedora              30 k
 libXrender          i686    0.9.9-1.fc22              fedora              30 k
 libXxf86vm          i686    1.1.4-1.fc22              fedora              22 k
 libattr             i686    2.4.47-10.fc22            updates             24 k
 libcap              i686    2.24-7.fc22               fedora              52 k
 libcom_err          i686    1.42.12-4.fc22            fedora              45 k
 libcurl             i686    7.40.0-7.fc22             updates            257 k
 libdatrie           i686    0.2.8-5.fc22              fedora              32 k
 libdb               i686    5.3.28-12.fc22            updates            763 k
 libdrm              i686    2.4.61-3.fc22             fedora             132 k
 libedit             i686    3.1-12.20150325cvs.fc22   fedora             100 k
 libffi              i686    3.1-7.fc22                fedora              33 k
 libgcc              i686    5.1.1-4.fc22              updates             91 k
 libgcrypt           i686    1.6.3-4.fc22              fedora             352 k
 libgpg-error        i686    1.17-2.fc22               fedora             123 k
 libidn              i686    1.32-1.fc22               updates            229 k
 libjpeg-turbo       i686    1.4.0-2.fc22              updates            160 k
 libpciaccess        i686    0.13.3-0.3.fc22           fedora              31 k
 libpng              i686    2:1.6.16-3.fc22           fedora             124 k
 libpng12            i686    1.2.50-8.fc22             fedora             159 k
 libselinux          i686    2.3-10.fc22               updates            150 k
 libssh2             i686    1.5.0-1.fc22              fedora             148 k
 libstdc++           i686    5.1.1-4.fc22              updates            444 k
 libtasn1            i686    4.5-1.fc22                fedora             327 k
 libthai             i686    0.1.21-1.fc22             fedora             193 k
 libtiff             i686    4.0.3-20.fc22             updates            177 k
 libtxc_dxtn         i686    1:1.0.0-4.fc22            rpmfusion-free      18 k
 libtxc_dxtn         x86_64  1:1.0.0-4.fc22            rpmfusion-free      18 k
 libverto            i686    0.2.6-4.fc22              fedora              21 k
 libwayland-client   i686    1.7.0-1.fc22              fedora              31 k
 libwayland-server   i686    1.7.0-1.fc22              fedora              37 k
 libxcb              i686    1.11-8.fc22               updates            205 k
 libxshmfence        i686    1.2-1.fc22                fedora              11 k
 llvm-libs           i686    3.5.0-9.fc22              fedora             8.7 M
 mesa-dri-drivers    i686    10.6.9-1.20151008.fc22    updates            8.5 M
 mesa-filesystem     i686    10.6.9-1.20151008.fc22    updates             35 k
 mesa-libEGL         i686    10.6.9-1.20151008.fc22    updates             98 k
 mesa-libGL          i686    10.6.9-1.20151008.fc22    updates            213 k
 mesa-libgbm         i686    10.6.9-1.20151008.fc22    updates             56 k
 mesa-libglapi       i686    10.6.9-1.20151008.fc22    updates             70 k
 ncurses-libs        i686    5.9-18.20150214.fc22      fedora             312 k
 nettle              i686    2.7.1-5.fc22              fedora             339 k
 nspr                i686    4.10.8-1.fc22             fedora             137 k
 nss                 i686    3.20.0-1.2.fc22           updates            871 k
 nss-softokn         i686    3.20.0-1.0.fc22           updates            319 k
 nss-softokn-freebl  i686    3.20.0-1.0.fc22           updates            196 k
 nss-util            i686    3.20.0-1.0.fc22           updates             81 k
 openldap            i686    2.4.40-12.fc22            fedora             346 k
 openssl-libs        i686    1:1.0.1k-12.fc22          updates            944 k
 p11-kit             i686    0.23.1-2.fc22             updates            148 k
 pam                 i686    1.1.8-19.fc22             updates            730 k
 pango               i686    1.36.8-6.fc22             updates            296 k
 pcre                i686    8.37-5.fc22               updates            495 k
 pixman              i686    0.32.8-1.fc22             updates            266 k
 readline            i686    6.3-5.fc22                fedora             203 k
 sqlite              i686    3.9.0-1.fc22              updates            487 k
 steam               i686    1.0.0.50-2.fc22           rpmfusion-nonfree  2.6 M
 systemd-libs        i686    219-25.fc22               updates            358 k
 trousers            i686    0.3.13-3.fc22             fedora             299 k
 xz-libs             i686    5.2.0-2.fc22              fedora              96 k
 zlib                i686    1.2.8-7.fc22              fedora              97 k

Transaction Summary
================================================================================
Install  99 Packages

Total size: 49 M
Installed size: 150 M
Is this ok [y/N]: y
Downloading Packages:
... #everything's [SKIPPED] Already downloaded since first run
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache till the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/gcc-5.1.1/python/libstdcxx/v6/printers.py from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
  file /usr/share/gcc-5.1.1/python/libstdcxx/v6/printers.pyc from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
  file /usr/share/gcc-5.1.1/python/libstdcxx/v6/printers.pyo from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
  file /usr/share/gcc-5.1.1/python/libstdcxx/v6/xmethods.py from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
  file /usr/share/gcc-5.1.1/python/libstdcxx/v6/xmethods.pyc from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
  file /usr/share/gcc-5.1.1/python/libstdcxx/v6/xmethods.pyo from install of libstdc++-5.1.1-4.fc22.i686 conflicts with file from package libstdc++-5.1.1-1.fc22.x86_64
  file /usr/share/doc/freetype/CHANGES from install of freetype-2.5.5-2.fc22.i686 conflicts with file from package freetype-2.5.5-1.fc22.x86_64
  file /usr/share/doc/fontconfig/README from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/fontconfig/conf.avail/10-scale-bitmap-fonts.conf from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/doc/fontconfig/fontconfig-user.html from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/doc/fontconfig/fontconfig-user.txt from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/man/man1/fc-query.1.gz from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/man/man1/fc-scan.1.gz from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/man/man5/fonts-conf.5.gz from install of fontconfig-2.11.94-4.fc22.i686 conflicts with file from package fontconfig-2.11.93-2.fc22.x86_64
  file /usr/share/locale/de/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.163-4.fc22.i686 conflicts with file from package elfutils-libelf-0.161-6.fc22.x86_64
  file /usr/share/locale/en@boldquot/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.163-4.fc22.i686 conflicts with file from package elfutils-libelf-0.161-6.fc22.x86_64
  file /usr/share/locale/en@quot/LC_MESSAGES/elfutils.mo from install of elfutils-libelf-0.163-4.fc22.i686 conflicts with file from package elfutils-libelf-0.161-6.fc22.x86_64
... #ran out of 30k char limit

Error Summary
-------------
10
  • If the 32-bits packages come from the official Fedora repos then they shouldn't cause conflicts with 64-bits counterparts. I would like to see the full output.
    – skytux
    Oct 31, 2015 at 1:02
  • @skytux I've pasted some output, though not all because it's long. I got the list of conflicting packages with a grep | sort | uniq from it though.
    – jozxyqk
    Oct 31, 2015 at 1:34
  • It might have something to do with a failed dnf update. When I first booted I updated, but froze mid way through (because of this) and had to restart. I tried looking for a "resume-transaction" like thing for dnf but gave up.
    – jozxyqk
    Oct 31, 2015 at 2:25
  • Firstly you should fix the incomplete update, otherwise you won't be able to install anything else. Do an dnf upgrade first to resume the update and then try again with the install. Thanks for having posted the output, it is the only way to know what is going on :)
    – skytux
    Oct 31, 2015 at 2:33
  • I ran clean all and upgrade again and it didn't seem to resume anything. I did find I had a newer kernel which wasn't being used and manually dnf reinstalled it which fixed the issue. package-cleanup --problems doesn't find anything but seems to be trying to use yum anyway.
    – jozxyqk
    Oct 31, 2015 at 2:38

3 Answers 3

7

As per the comments, the problem was with duplicate packages (~460 of them) from a crash during dnf update. The errors were about 32 bit libs conflicting with 64 bit libs of the older version when I also had newer 64 bit libs installed at the same time.

My solution was to remove the old ones with package-cleanup --cleandupes and reinstall the new ones (as some of them hadn't finished installing):

dnf repoquery --duplicated | sed "1 d" > dupes
cat dupes | sed 's/^\(.*\)-[0-9]\+:.*/\1/' | sort | uniq | grep -v kernel > reinstall
package-cleanup --cleandupes #uses dnf via /bin/yum (now a passthrough + warning script)
#check only the dupes are being removed before confirming "y"
sudo dnf reinstall $(cat reinstall)

steam installed just fine with the 32 bit libs after this.

5
  • I am on Fedora 23 and I don't have the package-cleanup command. Nor is it something I can find on the repos. Is there another way I can run a similar command to package-cleanup --cleandupes? I basically have a very similar situation as you have.
    – JoeMoe1984
    Feb 13, 2016 at 21:36
  • Nevermind, I figured it out. I will add it as an answer in case someone else needs to fix the issue on Fedora 23
    – JoeMoe1984
    Feb 13, 2016 at 21:54
  • Korora 22 Cinnamon. Same problem as OP: a corrupted dnf install put a mix of 64-bit and 32-bit drivers. My Palemoon Portable (yes, the Windows portable app in wine on GNU/Linux) broke. I followed these instructions and added specifically the elfutils-libs.i686 package based on my installed-list from a few months ago I saved to disk. Tada! Thanks so much, jozxyqk.
    – bgStack15
    May 27, 2016 at 12:55
  • @JoeMoe1984 I'm on Fedora 24 and I have it installed from yum-utils Oct 9, 2016 at 15:08
  • Now on Korora 25 Cinnamon, with only one set of "dnf update" since initial installation. I had this problem again, with just 4 duped packages. Now, though, the package-cleanup command is not available, but you can manually select the older-version package names and dnf remove $( cat everyotherline.out ).
    – bgStack15
    Dec 14, 2016 at 19:44
3

I had a similar problem as the OP. I did an update and the system failed during the update. I ran it again and things seemed fine.

Trying to install steam gave me similar package conflicts. I also had duplicate packages as well. Running the command dnf repoquery --duplicated showed all the duplicate packages.

I basically just did the autoremove command in dnf and then tried to install steam again.

dnf clean packages
dnf autoremove
dnf install steam

No more conflicts this time and it worked.

Notes I did read somewhere that autoremove can be kind of buggy sometimes so do use it with caution. Not sure if those bugs were fixed by now as the post I saw in a forum was dated back in October 2015 but it was something I found and thought I should mention it.

0

Things like

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/share/doc/pcre/AUTHORS from install of pcre-8.43-1.fc29.i686 conflicts with file from package pcre-8.42-4.fc29.x86_64
  file /usr/share/doc/pcre/NEWS from install of pcre-8.43-1.fc29.i686 conflicts with file from package pcre-8.42-4.fc29.x86_64
  file /usr/share/licenses/pcre/LICENCE from install of pcre-8.43-1.fc29.i686 conflicts with file from package pcre-8.42-4.fc29.x86_64
  file /usr/share/doc/gnutls/AUTHORS from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.4-1.fc29.x86_64
  file /usr/share/doc/gnutls/NEWS from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.4-1.fc29.x86_64
  file /usr/share/doc/gnutls/README.md from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.4-1.fc29.x86_64
  file /usr/share/licenses/gnutls/COPYING from install of gnutls-3.6.7-1.fc29.i686 conflicts with file from package gnutls-3.6.4-1.fc29.x86_64

Then just upgrade those x86_64 packages.

sudo dnf upgrade pcre gnutls

then, old x86_64 packages will be updated as the version be same with i686 packages. Then there are no conflicts.

Last metadata expiration check: 0:05:22 ago on Tue 09 Apr 2019 09:48:11 AM CST.
Dependencies resolved.
================================================================================
 Package           Arch          Version                   Repository      Size
================================================================================
Upgrading:
 gnutls            x86_64        3.6.7-1.fc29              updates        869 k
 pcre              x86_64        8.43-1.fc29               updates        186 k
 pcre-cpp          x86_64        8.43-1.fc29               updates         26 k
 pcre-devel        x86_64        8.43-1.fc29               updates        532 k
 pcre-utf16        x86_64        8.43-1.fc29               updates        172 k
 pcre-utf32        x86_64        8.43-1.fc29               updates        163 k

...

...

Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.

...
...

Upgraded:
  gnutls-3.6.7-1.fc29.x86_64             pcre-8.43-1.fc29.x86_64                
  pcre-cpp-8.43-1.fc29.x86_64            pcre-devel-8.43-1.fc29.x86_64          
  pcre-utf16-8.43-1.fc29.x86_64          pcre-utf32-8.43-1.fc29.x86_64     

...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.