9

I am not able to drag & drop anything into google chrome. For instance, I was able to add gmail attachments using drag & drop until yesterday but today it does not seem to work. Basically when I drag & drop anything onto chrome (not necessarily gmail) I see the 🛇 sign. Version of chrome is "46.0.2490.80 m" and I tried cleaning cahce, deleting temporary files, disabling touch features of chrome, re-installing chrome, uninstalling Avira (browser security), use different mouse, restarting Windows etc. BTW, Drag drop feature of IE and Firefox works just as expected. Actually it was working fine with chrome until yesterday. I tried drag & drop on another PC with very same version of chrome, it just works fine.

I suppose it is not about chrome but about Windows. What may be wrong with my system?

10

Somehow I set chrome.exe as "Run as administrator" from "Right Click Shortcut -> Properties -> Compatibility". Unchecking this solved the problem.

| improve this answer | |
5
  1. Point Chrome to URL: chrome://flags
  2. DISABLE: "Enable touch events"
  3. DISABLE: "Enable touch initiated drag and drop"
  4. Relaunch chrome

Source: https://github.com/dbushell/Nestable/issues/92

It fixed this issue for me.

| improve this answer | |
  • 1
    It makes sense why this would work (why listen for touch events when you don't have a touch device?). But, oddly, it had no effect on my problem. =\ – user530079 Oct 26 '17 at 17:46
  • Strangely enough, it also helped for me. Can anyone explain, why this seemingly unrelated touch display setting solves this mouse drag-and-drop problem? – Artanis Apr 28 '18 at 22:00
  • Tnx, works for me – YaserKH Apr 23 '19 at 6:07
3

You can try exiting and restarting Chrome. That just fixed it for me. (Maybe my Chrome instance had started as Administrator, but I don't know how/why that would have happened.)

| improve this answer | |
0

If you have a touch screen laptop, then this works to fix problem. Point Chrome to URL: chrome://flags DISABLE: "Enable touch events" DISABLE: "Enable touch initiated drag and drop" Relaunch chrome, works now!

| improve this answer | |
  • This is odd,  since the OP says they “tried ... disabling touch features of chrome”. – G-Man Says 'Reinstate Monica' Nov 3 '17 at 8:33
0

Had to disable "Touch initiated drag and drop" - then I was all good again. For me the symptoms were that the webpage blinked while I was holding the file over the webpage, before dropping. /JFK

| improve this answer | |
0

None of the answers above worked for me so I've installed Chrome Beta version and now drag and drop works.

It's not perfect solution but I don't care, choice is yours...

| improve this answer | |
0

Since the option for enabling "Touch events" is removed from Chrome in some and the newest version I wanted to contribute with a solution that worked for me. I got this from a thread from Google Groups. You can try change the target: inside properties for Chrome shortcut on desktop or the task bar.

This is the thread: https://groups.google.com/a/chromium.org/forum/#!topic/chromium-discuss/43EvDVGan6E

Here is a quick guide:

Chrome shortcut > Properties > Target field: "C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --touch-events

Enter "--touch-events" in the end like so. If it doesn't work try add "= enable" in the end also.

| improve this answer | |
-1

Running Chrome as an administrator is causing this problem. Just go to chrome.exe settings and disable it. Restart the browser and drag and drop is back.

| improve this answer | |
  • 1
    How does this differ from the accepted answer? – Ramhound Feb 5 '19 at 10:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.