13

In the language bar I have a "Dutch" language that I don't need and never use, hence I want to remove it. Here's a pictures of the language bar with the Dutch option:

http://i.stack.imgur.com/uF4Ri.png

The first thing I've tried is going to Control Panel > Time & Language > Region & Language and looking for any Dutch languages installed, but there are none installed:

http://i.stack.imgur.com/aE1so.png

Next, I went to Control Panel\Clock, Language, and Region\Language to see if there are any Dutch languages installed, but still no luck:

http://i.stack.imgur.com/bQo3T.png

The only Dutch program I have installed is an Microsoft Office Dutch Language Pack. Does that have to do with it? Is there any possible way to remove this language from the language bar? Thanks.

Edit: when I click on settings

http://i.stack.imgur.com/bQo3T.png

I also see just one language:

http://i.stack.imgur.com/FkBRU.png

  • 2
    @Ramhound Oh wow that actually did the trick. I added the language > installed the language (from Windows Update) > added the keyboards and then removed the keyboard + language and it's gone! Thank you very much. Is it possible to mark this comment as solution? Or do you have to submit a new answer? – jim Nov 1 '15 at 16:09
  • 1
    Possible duplicate of Keyboard language keeps changing in Windows 10 – Burgi Apr 17 '16 at 20:12
  • 1
    JimmyDG, @Ramhound, I have exactly the same problem. I tried following JimmyDG's suggestion, but I might have misunderstood the procedure. I clicked on the small "ENG" button near the bottom-right corner; "Language preferences" popped up, clicked on those; added Dutch; removed Dutch; checked the effect -- indeed Dutch was gone. But it only worked until I restarted Windows. Then Dutch was back in its place. How can I get rid of it permanently? The answer by xpy seems interesting, but I am afraid to experiment with the registry, and I do not quite understand what exactly I should do there. – Richard Hardy Jul 9 '16 at 14:10
  • @Ramhound, thanks for a quick response. Well, just for the record, it did not work for me. – Richard Hardy Jul 9 '16 at 14:47
4

I found an answer that solved the problem for me.

http://answers.microsoft.com/en-us/windows/forum/desktop/my-keyboard-layout-is-switching-automatically-by/98eda57a-c225-45b2-a233-42f21fadb0cd

The only step I did was to go to the registry, to HKLM\SYSTEM\CurrentControlSet\Control\Nls\Language\Defaultand change the REG_SZ value to the language I wanted.

here is a list of all the language codes

  • I tried changing the default value but got a message "Cannot edit Default: Error writing the value's new contents". Do I have insufficient permission (I am not the ultimate administrator)? Also, there is a field (Default) with value (value not set). Does that one matter? – Richard Hardy Jul 9 '16 at 14:30
4

To solve the language keep adding itself issue follow these steps:

  1. go to Control Panel -> Language
  2. from the sidebar select "Change date, time, or number formats"
  3. select "Administrative" tab.
  4. in the "Welcome screen and new user accounts" box click "Copy settings.." button
  5. Check the two boxes under "Copy your current settings to"
  6. the windows will ask you to restart the computer then you finish :)

the original answer from Microsoft Community

  • 1
    Oh of course. So obvious in retrospect! <rolling eyes> – Brian White Apr 28 '18 at 22:13
1

I had a similar problem in a swiss environment. My language settings listed only two languages: swiss german and russian, which I also wanted to have. But the language box in the task panel listed 4 languages: swiss german, standard german, swiss french and russian.

I have found the solution for me in a pretty old posting blogspot post: http://botsikas.blogspot.com/2010/02/unwanted-languages-in-language-bar.html

What I basically needed to do is to remove unwanted languages from Microsoft Office Language Settings.

-1

I had the same problem: lots of languages in language bar (each added when I installed different language versions of a software), yet only two listed in the Control Panel - so I couldn't remove them from there.

The solution: 1. remove the language-version software that you no longer need 2. RESTART THE COMPUTER. This does wonders.

protected by Community Mar 19 at 20:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.