48

The brightness changes with the colors displayed on the screen on my Lenovo Thinkpads with Intel HD Graphics. Light colors make the screen brighter, dark make it darker. Same behavior in Windows 8.1 and 10.

The "adaptive brightness" feature in Windows is disabled.

54

Just found a suggestion that solved my problem here.

It is the Intel "Display Power Saving Technology" that is to blame.

Disable it like so:

  1. Launch "Intel HD Graphics Control Panel" by right clicking and selecting "Graphics Properties..." from your Intel HD Graphics tray icon
  2. Click Power
  3. Choose "On battery"
  4. Select "Disable" for Display Power Saving Technology
  5. Click Apply

Intel HD Graphics Control Panel example

  • My charger was connecting and disconnecting repeatedly because it was overheating (it has a safety feature to turn off at a certain temperature). This didn't occur to me for half an hour. Unlikely, but worth noting. – person27 May 14 '17 at 22:27
  • 2
    Make sure to restart your computer to fully apply the changes – Chris McFarland May 27 '17 at 3:41
  • I'm running HP Envy and everything I've tried worked only for a short time, until restart or wake up. The only solution was to unplug power cable and plug it again. – opewix Sep 7 '17 at 12:52
  • Thank you so much. I was figuring out the issue from last week. – zackygaurav Jan 22 '18 at 11:54
  • 1
    the "Intel HD Graphics Control Center" app is no longer maintained, Intel however did publish a replacement app called "Intel Graphics Command Center" and turning off "Display Power Savings" (System -> Power -> Battery) did the trick and never reverted back afterwards. – Ahmad Nassri Jan 8 at 19:21
31

Even after changing the "power" options in the "Intel HD graphics control panel" the brightness kept adapting to the image brightness/darkness.

So did some research and found a solution through editing the registry.

instructions:

  1. press Win+r
  2. type regedit and press Enter
  3. navigate to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Brighten Movie and change ProcAmpBrightness to 0
  4. also navigate to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Darken Movie and change ProcAmpBrightness to 0

This should solve the problem.

  • These reg. values are not in my registry..? – petersv Mar 20 '16 at 17:00
  • do you have to restart? this is still not working. – ahnbizcad Oct 19 '16 at 15:44
  • 1
    For me it works after reboot – Riccardo Jan 13 '17 at 15:44
  • 1
    You are a total genius! There is another way to do this. I believe you can change the brightness in brighten and darken video from the Intel graphics properties interface -> Profiles -> selecting the aforementioned profiles and saving the changes after loading the profile and resetting the brightness. – wolfdawn Feb 21 '17 at 7:00
  • 1
    Thank, this works. Either reboot, or if you have two display adapters in your computer, disable and enable intel HD graphics for the modifications to take effect. – Soma Deáki Feb 28 '17 at 12:07
6

So i just fixed this problem temporarily. What i did is i went to Device Manager, then went to Display adapters.

Now i have 2 graphics cards in my system, one is an integrated Intel HD4000 and the second is a Geforce GT740M so i dont know if this will work on systems with 1 graphics card.

After this just disable and enable your integrated graphics card and it should fix it.

  • This did the trick for me. Somehow my display defaulted to Intel graphics when I have AMD Radeon – F0r3v3r-A-N00b Sep 12 '17 at 12:46
  • this is the only option that helped me – andreikashin Feb 14 '19 at 21:22
0

I tried so many of these fixes and nothing worked. I was finally able to beat this problem though. I have an i7 processor with integrated HD graphics but also have an nVidia card as well. During Windows 10 setup (or maybe before) my integrated HD card was disabled in my BIOS. I had to enable the integrated HD graphics and then in Windows install the newest HD graphic drivers. After the drivers installed all my tweaking around in the power options screen actually did something. Your mileage may vary but I think enabling the disabled integrated video chip in the BIOS and installing the proper drivers is what was missing. At least for me.

  • 1
    You didn't specify what you tweaked. You explained how you solved the problem, but could you reproduce the steps you took to solve the problem? If you could find out some other information on what you changed, you should update your answer. – DrZoo Jul 5 '16 at 22:07
  • This topic is for the Intel HD Graphics. I suggest you add a new question/topic for this answer. – petersv Jul 20 '18 at 12:51
-1

Everything here didn't help and in the end the problem was in the monitor itself - it is a mag monitor went into the monitor's settings (the physical menu button on monitor) and go into color and change DCR mode to off

-1

I had the same problem and also tried all of those fixes and nothing worked till now. I use a secondary monitor for my laptop and was able to fix the problem when I disconnected the secondary monitor, restarted the power plan from the advance power setting ("restore plan defaults"), then restarting my laptop and after that changing the adaptive brightness to off. It works just fine now.

-1

I've looked around the web and there appear to be several possible causes and solutions to this problem depending on your Windows version and hardware. Here's a compilation of how to turn off adaptive brightness.

  1. Go to Power Options > Display > Enable Adaptive Brightness > Set it to Off in both places

enter image description here

  1. Go to AMD Catalyst Control Center > Power > PowerPlay > Uncheck the "Enable Vari-Bright" box

enter image description here

  1. Go to the Intel Media and Graphics Control Panel > Power > Disable Intel Power Saving Technology

enter image description here

  1. Go to Services > Disable the Adapative Brightness service

enter image description here

  1. In regedit:

    Go to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Brighten Movie and change ProcAmpBrightness to 0

    Go to HKEY_LOCAL_MACHINE\Software\Intel\Display\igfxcui\profiles\media\Darken Movie and change ProcAmpBrightness to 0

  • This is probably a great solution for AMD graphics, but this topic is for the Intel HD Graphics. I suggest you add a new question/topic for this answer. – petersv Jul 20 '18 at 12:50
-2

Here's the easy way I found: Adaptive Brightness Control

enter image description here

  • OP stated that he already had adaptive brightness turned off – Gust van de Wal Jun 6 '18 at 15:27
-3

This happened to me also. I tried all of the other solutions but none worked. Then I noticed that my desktop background was not my usual.

I right-clicked on the desktop, chose "Personalize" and in the Background slot, I chose "Picture" and clicked on the picture I wanted. The problem went away.

Not the answer you're looking for? Browse other questions tagged or ask your own question.