2

I am using emacs version <24.4, and since I don't have root permissions on the system, I can't upgrade to a newer version.

While trying to install magit, I get the following error:

Package `emacs-24.4' is unavailable

There are some other people who already asked this question on the web, but since I am an emacs newbie, I don't yet understand the terminology they were using.

I will appreciate any assistance.

Thanks!

2

I am assuming you're trying to install magit though Melpa, so you probably downloaded the latest magit which is 2.3, and requires at least Emacs 24.4. If you don't have root access to the machine and can't upgrade any package, you'll have to fall back to the previous major version (1.4.2) which requires Emacs 23.2.

You can start by checking the README file of the 1.4.2 tree of magit at github, which has some basic information, but the real instructions are available at V1 documentation, which has some instruction for installing older versions.

Be aware that the instructions include some code you should put into your emacs configuration files, which is usually ~/.emacs.d/init.el. Since you mentioned you're an Emacs newbie you might not know how to place those lines into your configuration, so I recommend you to read a bit about it, it will be very useful for your Emacs life. Emacs manual and EmacsWiki can be good starting points. Some users use git to keep track of their configuration, so they can deploy their customized Emacs on almost any computer they need to work.

On the matter of lack of root access, one point to consider is that some distros are still using Emacs 24.3 and even with root access you won't be able to update, this is the case for Ubuntu 14.04 LTS and derivates. So even if you had admin access to the machine you'd still need to download and install Emacs from a secondary source other than your distro's repository, which in the end might not need root access (local install).

| improve this answer | |
  • Thanks for the detailed answer. I didn't understand your last paragraph. Could you elaborate a bit? – Yuval Atzmon Nov 1 '15 at 19:11
  • 1
    Ubuntu 14.04 "Trusty Tahr" is what they call Long Term Support or LTS, which is intended to be a "stable" distro, so new packages are usually security fixes, assuming that you are updating though Canonical official repositories. Current Emacs version for this Ubuntu is 24.3 (launchpad.net/ubuntu/trusty/+source/emacs24) I don't know any way of updating except downloading the sources and compiling yourself, but I didn't make a proper research. My point is: maybe you can compile Emacs and run locally (within your home folder) without root access. The other option is install the old magit. – Henrique Jung Nov 1 '15 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.