2

So I have a Surface Pro 3 running Windows 10, and an external USB 3 HDD. If I plug in the HDD, a process will begin. First the drive will appear with the drive letter only, and be unreadable, but in an unusual way. Any software that attempts to interact with it will hang until it either crashes or the drive is disconnected. During this stage the drive may disconnect and reconnect multiple times. If left in for long enough, the drive will finally show up with it's name, and be readable. However it still disconnects and reconnects.

Steps I have tried:

  • Disabling the power saving features for all USB devices in Device Manager
  • Reinstalling all USB drivers
  • Testing hard disk on my desktop computer (where it works fine).
  • Powering down the drive for an extended time before trying again
  • Your USB port may not be providing enough power to support your external. Is it a 2.5" or 3" drive? – QMord Nov 1 '15 at 6:15
  • It's 3.5, but it has it's own power supply. – Adrian Smith Nov 2 '15 at 5:42
  • Did you make sure you updated the drivers from your laptop manufacturer's website, rather than Windows updates? Another thing that could be causing this issue is a shortage of power supply in the USB port itself. I'd suggest you to try all the ports on your laptop and see if get properly detected on all of them, without disconnecting. Could you please share how the drive appears in Disk Management on your laptop as well? I'd also recommend you to backup your data from the external on your PC (since it properly recognizes the drive) before proceeding with the troubleshooting. I'd also try plugg – SuperSoph_WD Nov 2 '15 at 11:30
  • The laptop is a Surface Pro 3, so the manufacturer is Microsoft. The Surface Pro only has 1 USB port. The drive in it's first stage will not appear in disk manager at all, the application will simply hang when it tries to get partition lists. The external drive is actually just a backup/copy of a drive on my main PC. I will add in case it is relevant, that the external drive is an enclosure for a 3.5" drive. – Adrian Smith Nov 3 '15 at 1:15
  • @AdrianSmith I'd suggest you to try using a different USB cable then. I'd recommend you to test the HDD using its manufacturer's diagnostic utility to check up on the health and SMART status. You should be able to find it on their official website, since you have trouble with external on your laptop, do the diagnostics from your PC instead. Keep me posted with the results! Good luck! – SuperSoph_WD Nov 3 '15 at 8:43
2

Many laptops have issues with supplying the power needed for a proper USB3.0 Connection, even if they are plugged in. To fix this, I recommend a number of steps.

Solution 1

  1. Go to power & sleep settings
  2. Additional power settings
  3. Change plan settings
  4. Change advanced power settings
  5. USB settings
  6. Disable USB selective suspend

See if the error still occurs

Solution 2

  1. Go to the Device Manager from the control panel
  2. Find the Universal Serial Bus controller you are using
  3. Disable selective suspend (sometimes the power settings just don't seem to cut it)

Solution 3

  1. Go to you BIOS
  2. Look for a fast charge option and enable it

Not all BIOS chips have this option.

Solution 4

  1. Go to your BIOS
  2. Disable Legacy USB Support

Not all BIOS chips have this option. But it's good to try.

Solution 5

  1. Go to your BIOS
  2. Disable C-States

As with all BIOS options, it may not be part of your machine, but if it is it should fix your problem.


Make sure that any changes you make to your BIOS, you keep track of. Also, if the BIOS solution didn't fix your problem, reverse what you did first before you change something else, the developers made these default options for a reason.

  • 1
    This post is super old, and I no longer have this device. I remember trying at least 1,2, and 4 and they didn't work for me. However, I'm going to mark this solved anyway as I no longer have a way to verify and I know that these have worked for other people with similar problems. – Adrian Smith Jun 16 '17 at 21:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.