18

I'm on a Lenovo Y50, running Windows 10.

I have an external monitor attached (HDMI) and I use the laptop screen as well as the external. Sometimes I want to close the laptop lid and just use the one screen. When I close the laptop lid, the screen turns off, but Windows still thinks of it as a valid display, and as such, doesn't move my windows and stuff from the laptop screen to the external screen. Every other laptop I've had has disabled the laptop screen on closing the lid, thus making the OS behave as if there's only one display connected.

This is particularly annoying because I'd like to be able to move my mouse to the edges of the screen without it moving off into another screen that I can't see because the laptop lid is closed.

Is this a problem I can solve? I'd like the laptop to let the OS know that the display has been disabled when the laptop lid is closed.

  • 1
    Is it possible your computer's has a broken sensor for detecting the lid being closed? Try setting the power plan to go to sleep when closing the lid, then close it and see what happens. – LevenTech Nov 1 '15 at 4:20
  • No, the screen definitely turns off when I close the lid, but the OS doesn't stop treating it as a working display. – AVP Nov 1 '15 at 15:27
25

Try Win+P -> "Second screen only" Set 'what happens when lid is closed' to 'do nothing' in Control Panel->Power Options->choose what closing the lid does

  • 3
    Is there no way to do this automatically when I close the lid? – AVP Nov 1 '15 at 15:26
  • Win+P did the job. It shows the second monitor only when hdmi plugged in, and shows the main monitor when hdmi removed. – Zachary Scott Nov 6 '17 at 4:52
  • This doesn't work if you have two external displays and want the built-in display to turn off. If you have two external displays, "Second Screen Only" shuts down one of the externals as well as the built-in. – Todd Wilcox May 23 at 19:40
  • This worked for me using Windows 10 1903 and two external monitors. Win-p, show second screen only left the two externals running. One is connected via HDMI, and the other with a USB HDMI adapter. – Ben Birney Aug 25 at 9:34
5

See below for how I do it. Here is a good ref I used to help me -


My Setup

  • (1) Laptop (Win10 Home)
  • (2) LCD Monitors

Need

  • Output to both displays with laptop closed and laptop-display off

Steps

  • Open Settings->Display ('Change Display Settings')

  • Identify which display you'd like to disable (#1 for me)

  • Select display (tap on #1)

  • Scroll down to 'Multiple displays', set to 'Disconnect this display' & Confirm


Here is how to confirm, Settings will show greyed out if off -

  • This works for multiple external monitors. Thanks! – Todd Wilcox May 23 at 19:44
  • 1
    Ah, one major downside with this. When you disconnect your external monitors and open the laptop lid, the laptop display is still disabled. – Todd Wilcox May 23 at 20:40
  • Thank part continues to annoy me, each time I bump into it. Not too big tho, just a nuisance – J-Dizzle May 24 at 1:26
2

This will be sort of an addendum to J-Dizzle's answer I'm making because I couldn't find the 'Disconnect this display' option in the last step.

The only real difference is ensuring your laptop monitor is not your main display before trying to disconnect it. Perhaps this is common sense, but it took me a while to figure out. Big thanks and credit to J-Dizzle for his answer though!

My Setup

  • Windows 10
  • Two LCD Monitors

Need

  • Output to both displays with laptop closed and laptop display off
  • Continue to have the laptop display off when I wake my laptop from sleep

Steps

  1. Open 'Change Display Settings' (search for that in the start menu or right click the desktop and click 'Display Settings')
  2. Open your laptop lid
  3. Identify which monitor is your laptop monitor (#1 for me when laptop is open)
  4. Select one of the monitor displays (#2 and #3 for me)
  5. Scroll down and click 'Make this my main display'
  6. Select your laptop display (#1 for me)
  7. Scroll down to the 'Multiple displays' dropdown menu and click 'Disconnect this display'

Here is how to confirm, Settings will show greyed out if off -

0

Something you should know about: Win10 creater update version can play a role in this too:

https://forums.lenovo.com/t5/forums/v3_1/forumtopicpage/board-id/tp01_en/thread-id/116179/page/1

  • Add more than just the link please because when the link goes bye-bye, and answer with just the invalid link is useless. Quote the content from the link you feel helps with the question. – Pimp Juice IT Aug 8 '17 at 13:26
0

On my Windows 10, version 1703, I am usually using laptop display and a second screen on an extended mode. When I want to use just the second screen, I just need to close the lid. The second screen will become the only recognized by OS and will gather all windows that were running on my laptop display.

Important to note that I configured my Power Settings to "Do Nothing" when lid is closed. Tested with both "on battery" and "plugged in" and both work.

-1

You need to setup the settings to do nothing if laptop lid is closed and laptop is plugged-in to the power. To make these settings, you need to go to Power Option. Under Control Panel screen, search for the Power Option. It will give few options. Select "Change what the power buttons do". This will let you set the option while laptop lid is closed.

  • Your recommendation seems counter intuitive. Can you provide an explanation as to how this setting will result in Windows disabling the display when the lid is closed? – I say Reinstate Monica Feb 21 '18 at 18:42
  • Basically you need to set "Do nothing" under the Power settings. You need to go to Control Panel and then go to Power Option. The screen you get will have option to set the preference for the laptop lid closed option. – Mayank Goel Feb 23 '18 at 0:46
  • Do Nothing tells Windows not to do things, such as sleep, hibernate, etc. It's also not going to disable the display, which is what the OP wants to happen. – I say Reinstate Monica Feb 23 '18 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.